1 Reply Latest reply on Dec 9, 2007 6:14 PM by BenZhang

    Urgent - wmode issue with iFrame

    danfulz
      On our Flex application, we need iFrame components for playing youTube videos, displaying some html text and integrating some Google Adsense. Be able to display iFrame in front of application, we need to set up "wmode" parameter, "opaque" as value in html source code, but too many troubles come out if we set "wmode" parameter for our application.

      1. The transition performance issue: the transitions becomes very slow
      2. The mouse scrolling function is freezen on Firefox: by scrooling middle wheel on mouse, the page doesn't move up or down
      3. When flex popup window displays out, everything (video, html text) in iFrame is still displayed in front of flex popup. This causes some action buttons on flex popup window cannot be clicked.
      4. When we play youTube video in iFrame, the cursor can focus on input box, but we can type text inside of input box in Firefox

      All problems is coming from the "wmode" we setting up in html source code. Could someone got same kind problems, and give some good suggestions for us, that will be appreciated.
        • 1. Re: Urgent - wmode issue with iFrame
          BenZhang
          We are currently working on a Flex application for consuming all types of media – a next-generation media consumption platform. We launch in January and urgently require a fix. The issue we are experiencing is as follows: We need iFrame components for 1.) playing YouTube videos, 2.) displaying some html text and 3.) integrating Google AdSense. In order to display iFrame in front of application, we need to set up "wmode" parameter, "opaque" as value in html source code, but we get a long list of troubles when we set "wmode" parameter for our application.



          1. Transition performance issues: the Transitions become very slow, and not very smooth

          2. Mouse scrolling function is frozen on Firefox: Using the middle wheel on a mouse is disabled…the page doesn't move up or down. When we do scroll by dragging the scroll bar, video does not scroll smoothly with application and sometimes stops in wrong place.

          3. When flex popup window is displayed (video, html text) the iFrame is still displayed in front of the flex popup. This means that some action buttons on the flex popups cannot be clicked.

          4. When we play YouTube video in iFrame, the cursor can’t focus on any input boxes (i.e. search box). We need to click on url box to reset focus and then we can type in input box…a Firefox issue.

          All of these problems are coming from the "wmode" we set up in html source code.

          If anyone can please provide some assistance or suggestions, it would be greatly appreciated. We would even consider financial reward for a solution to these issues.