8 Replies Latest reply on Sep 5, 2017 6:58 AM by ChiefLar

    Target channel is hidden

    Elliott B. Level 1

      In Photoshop CC, I am constantly getting the message "Could not ...... because the target channel is hidden" whenever I try to do anything.  Every time, I check and see that the alpha channel is selected and hidden, so I select RGB instead.  Why does it keep automatically switching back to alpha?

        • 1. Re: Target channel is hidden
          Noel Carboni Level 7

          Are you maybe clicking on a layer mask icon in the Layers panel?

           

          -Noel

          • 2. Re: Target channel is hidden
            Elliott B. Level 1

            Nope.  I did have some layer masks, but they were inside layer groups that were closed and not visible.

            • 3. Re: Target channel is hidden
              Noel Carboni Level 7

              I'm not sure what you might be doing, but I haven't heard a lot of complaints here on the forum about Photoshop selecting alternate channels on its own...  Is is possible you're fat-fingering a key on the keyboard just before this happens?

               

              I'm scouring my memory and I can't think of a time when I've had a channel made active without being able to explain it...

               

              I can only encourage you to watch for it to happen then very carefully review what you've just done.

               

              Next time it happens, before changing anything consider doing a screen grab and posting it here.  Maybe there's some other clue there that one of us on the forum might be able to spot.  Maybe something will be showing in the History panel that will make it clearer...

               

              -Noel

              • 4. Re: Target channel is hidden
                EmmanuelMota Level 1

                I am getting the same exact issue.

                I very carefully select my layer and go to move it using the cursor, and get this error.

                I look in the channels panel and RGB is no longer selected only the Alpha channel.

                I edit text, save changes, go to move the layer and get this error.

                This is the first time this has happened to me as a photoshop user of 10 years. I am on Creative cloud cc and just updated photoshop a few days ago..

                 

                The only fix I know of is to select the alpha channel and delete it..

                Screen Shot 2014-01-03 at 9.38.40 AM.pngScreen Shot 2014-01-03 at 9.38.50 AM.png

                1 person found this helpful
                • 5. Re: Target channel is hidden
                  Qynchou Level 1

                  I had the same problem and found the solution:

                   

                  Your top panel, go to Select then in the dropdown menu uncheck "Edit in quick mask mode". Then it switches back to automatic RGB channel selection from automatic Alpha selection.

                  6 people found this helpful
                  • 6. Re: Target channel is hidden
                    paul.carkhuff Level 1

                    In my case I found out that when I was accidentally right clicking on the curves icon, when I meant to left click on it. I have a wireless mouse and it's easy to do:( This had the effect of creating a layer mask in a curves panel, instead of just a layer with curves adjustment. Since the curves panel showed up right where I expected it, I failed to notice that I was creating a layer mask with a curves in it. Then I went to use my eraser and got the same message. It kind of messed me up for a while, but I solved it by deleting the unwanted layer, and then deleting the alpha channel which was also inadvertently created. I had a similar problem with using the option key when using the quick selection tool. I heard a click, click, click, etc. and then my keyboard was inactivated. I resolved this by hitting the option key multiple times until I heard the click, click, etc. again. There are numerous ways to get in a weird setting that is not helpful, and then it takes forever to figure out what happened and how to fix it. Especially since it's unintentional, a person has no idea what they might have done. Luckily sometimes there is a sound to indicate that something weird happened.

                    • 7. Re: Target channel is hidden
                      olim92435738 Level 1

                      You are in quick-mask mode

                       

                      Push the letter Q and all your troubles will go away...

                      • 8. Re: Target channel is hidden
                        ChiefLar Level 1

                        Worked, thanks.