1 Reply Latest reply on Dec 7, 2007 11:31 AM by AnnFreeman

    RH 7: JavaHelp - can't build Full-text search or virtual machine

    AnnFreeman Level 1
      I build JavaHelp from RoboHelp for Word, using legacy files. I have recently upgraded to RoboHelp 7 in order to produce Japanese, Russian, and Turkish JavaHelps. However, with RH 7, when I run the single source layout to build my JavaHelp, I don't get the full-text search database. The compile window reports:
      Building Full-Text-Search data...
      Could not create the Java virtual machine.
      Unrecognized option: -locale

      This happens on a new test program with only a single topic or two - not just my existing help project.

      I have tried both JH 1.1.3 and JH 2.0 to no avail. I have the jhtools.jar in my javahelp/lib folder that has been necessary in the past for JavaHelp builds / searches.

      I have tried numerous versions of the Java Development Kit or Software Environment: jdk1.6.0_03, 1.5.0_14, 1.4.2_06, and probably some others.

      I have uninstalled and reinstalled RoboHelp 7 numerous times.

      I have cleaned out the SingleSource entries in the registry pertaining to JavaHelp and the Java SDK such that RoboHelp will prompt me to browse to whichever Java SDK or JavaHelp I am trying.

      I can't seem to find a combination that will work.

      Any help would be appreciated.