4 返信 最新の回答 日時: Dec 20, 2013 12:38 AM ユーザー:explasm

    動画読込時に自動作成されるフォルダの日付が狂う

    explasm

      Windows 7 64bit で使用しております。これはLightroom5.3の最新版でも確認された現象です。
      ただし、日本語版特有の可能性もあります。

       

      SDカードなどから動画データを読み込む際に自動的に日付のフォルダが作成され、そこに読み込まれます。ところが、動画データのタイムスタンプが15:00をを過ぎていると日付が1日加算され たフォルダが作成されてしまい、そちらに読み込まれてしまいます。

      たとえば、動画ファイルのタイムスタンプが2013/12/17 14:59であれば"2013-12-17"という正しいフォルダが作成されますが、2013/12/17 15:00なら"2013-12-18"というフォルダが作成され、そちらへ読み込まれます。

      この現象は写真データでは発生しません。

      15:00という時間は日本時間なのに、標準時刻と解釈して9時間足して日付を導出していると思われます。

      私のカメラはSONY NEX-5Nで、動画はAVCHDタイプです。カメラ側に問題があるのでしょうか?

        • 1. Re: 動画読込時に自動作成されるフォルダの日付が狂う
          jjj5555

          Windows7 64bit  Lightroom5.3

          という全く同じ環境で使っていますが、自分も全く同じ現象で困っています。

           

          ただし、違うのは、そちらでは 「この現象は写真データでは発生しません」 だそうですが、
          こちらでは、写真データでその現象が出ます。  動画データは、すみません、試していません。

           


          Lightroom2 の時にはこの問題はありませんでした。
          4 にアップグレードした時から、この問題が出ました(3は使っていないので、わかりません)。

           

          今回 5.3 にアップグレードしてみると、やはり同じ現象が出るので、困っているところです。

          整理上、非常に(致命的なくらいに)不便です。

           

          このリンク↓を見ると、1.0 の頃に不具合があって、1.1 で修正されたように見えます。
          http://kb2.adobe.com/jp/cps/231/231891.html

          ですが実際は、このように 5.3 でも起きています。


          Lightroomの不具合なのか、カメラとの相性などがあるのか、対処方法はあるのか、情報が欲しいです。

          使用しているカメラは Canon EOS KISS X です。 WindowsPC に USB ケーブルでつないで読み込みをしています。

           

          ※解決にならないばかりか便乗質問のような形ですみません。

          • 2. Re: 動画読込時に自動作成されるフォルダの日付が狂う
            explasm Level 1

            jjj5555さん、追加の情報ありがとうございます。

            Ver.1時代にも同様の問題があって一度修正されていたのに再発したのだとすると、かなり最低な開発管理をしていると言うことになります。
            というより、むしろ日本語版などのマイノリティーを無視している可能性もありそうですね。
            私はVer.4から使用していてこのときから同じ問題がありました。しかし、報告する場所が無いのでどうしようもありませんでした。現在もその状況に変りはありませんが。

            非常に稚拙なバグが潜んでいそうですね(私もシステム開発者なのでなんとなく分かります)。

            • 3. Re: 動画読込時に自動作成されるフォルダの日付が狂う
              jjj5555 Level 1

              その後ですが、知り合い2人に聞いてみると、ニコンやキヤノンのデジイチ + LR5.3 や LR4.4 などで、この問題は起きていないそうです。  よって、この現象は起こる環境と起こらない環境があるようです。  想像ですが、ほとんどの人には起こってないのでしょうかね。 ほとんどの人に起こることであれば、アドビ様が対処してくれるだろうからです。

               

               

              で、全くの当てずっぽうですが、試しに読み込み手順を変えてみました。 今まではカメラを USB ケーブルで PC につなぎ、LR の 「読み込み」 で直接このカメラを指定して読み込んでいました。  それを変えて、Windows のエクスプローラを使って写真ファイルを(フォルダごと)HDDに手でコピーし、LR の 「読み込み」 ではこのHDD上のフォルダを選ぶようにしてみました。 すると、あっさりこの現象は消えました。 15時以降のファイルでもちゃんと撮影日の日付のフォルダに入ってくれています。

               

              その後、もう一度カメラから直接読み込んでみたら、やはり、15時以降の写真は翌日のフォルダに入ってしまいました。

               

              このことから、少なくともうちの環境では、カメラから直接読み込むと問題があり、HDDからであれば問題ない、ということが分かりました。 面倒ですけど、今後この方法でやって行こうと思っています。  この結果を見ると、日本語版かどうかではなく、何か読み込みの方法だとか、ドライブのマウントの方法だとかに影響されるように見えるのですが、どうでしょうかね。

               


              そちらでも同様のやり方で解決しないか、試してみて、お知らせ願えないでしょうか。参考にしたいです。

               

               

               

              アドビ様はこの問題は認識しているのでしょうか。
              アドビスタッフの人は、この書き込みなど、見ているのでしょうか。
              フォーラムなどで下手なことは言えないのでしょうが、

              解決方法があるわけではないが問題の認識だけはしているだとか、
              不具合かどうかはともかくそういう報告があったというところまでは了承しているだとか、

              何かしらレスポンスが欲しいところです。

              アドビが用意しているフォーラム内で、

              問題が起きているカスタマーの間のみでああだこうだ言って、

              開発側は何も言わないというのはとても違和感があるので、

              アドビ様何卒ご検討下さい。

              • 4. Re: 動画読込時に自動作成されるフォルダの日付が狂う
                explasm Level 1

                コンピュータ内部の日付の管理は世界標準時+国別の時間差となっている部分や、最初からローカルタイム(その国のその地域の時刻)のみを管理する場合とがあります。

                Lightroomのバグはその辺りの時刻データ管理がごっちゃになっているのでは無いかと思われます。

                 

                通常、プログラムからUSB経由で見た場合とメモリーカードを直接コンピュータに挿して見た場合、使用されるデバイスドライバ(OSとデバイスを結びつけるプログラム)は異なる可能性はありま すが、いずれにしてもファイルシステムとして見える時刻は同じはずと思うのです。プログラムは、OSからファイルのローカル時刻を読み込んでそのまま使えばいいはずで、簡単な話のはずなのです 。
                USB経由の場合だけで結果が異なるのは、Lightroom自体の動作するプログラムコードが異なるのかもしれませんが、そのあたりはちょっと想像出来ません。

                 

                ただ、Lightroom自体のバグである可能性が高いのは、読み込んだデータファイル1つ1つの日時はきちんとカメラで撮影したものになっていることです。日付の判断だけがおかしいのは、L ightroom自体のバグと言えます。

                 

                国によっては夜中に撮影したものしか狂わないとか、気がつきにくい可能性もあるのではないかと考えていますが、言語によって動作するロジックが異なっている可能性も考えられます。

                 

                日本語版を売っていながら、日本語のサポートが実質無いのはおかしいです。だからこういう結果を招くのだと思うのです。

                 

                USB接続時の実験は機会をあらためてやってみたいと思います。

                 

                追記:

                別のスレッドでアップしましたが、読込時のLightroomで読み込みフォルダを新規作成すると、新規フォルダが読み込み画面に現われない現象がありますが、それはございませんか? これは言語に関係なく世界共通のバグのように(Windows版だけかも)思うのですが・・・