8 Replies Latest reply on Jan 8, 2014 1:59 AM by CatJonne

    Images are missing in Project Manager

    CatJonne

      I’m replacing old images with new ones in RoboHelp HTML 10.

       

      I’ve deleted the old pictures in Design view and pasted the new pictures in. (I know this is not the recommended way but with lake of time I found it to be the fastest way and we don’t feel the need to give the files described names at the moment.)

       

      It has worked fine until now when I noticed that some images are not showing in Project Manager. I see the “folder” Images and I see a lot off images there but some are missing. The “missing” images are shown in Design view and in the browser after publishing. But in the report Unused files the “missing” images are listed as unused.

       

      I have tried to

      • close and reopen the project,
      • generate and publish the project,
      • delete an “missing” image from Design view and insert it by using Insert / Image. After saving this image, and some other “missing” images, are shown in Project Manager. But not all “missing” images.

      Does anyone know why this is, or more important how to get Project Manager to show all images that are used in the project (without having to go through all 154 images trying to figure out which are used but “missing”)?

       

       

      Some more facts:

      • They are all gif-images.
      • They are all stored at the top-level in the project folder. (Are there a limit how many images there can be in the top-level folder?  Should I create a separate folder and move the pictures there?)
      • HTML-code for one “missing” image:

                <img src="image7.gif" alt="" style="border: none;"

                                                                                                                  

                       border="0" />

       

      Grateful for any input!

        • 1. Re: Images are missing in Project Manager
          Peter Grainge Adobe Community Professional (Moderator)

          I would have said "Try renaming the folder containing the images in Rh's Project Manager. That sometimes fixes the problem. You can revert to the old name afterwards."

           

          Keeping all the images, and / or topics, in the root is never a good idea. It can slow things down and it's messy.

           

          You can move the images you can see but obviously you cannot move the others. Try moving a topic that has one of the images to a different folder and see if that refreshes. Also try deleting the CPD file and reopening Rh.

           

          Backup first.

           

           


          See www.grainge.org for RoboHelp and Authoring tips

           

           

          @petergrainge

          1 person found this helpful
          • 2. Re: Images are missing in Project Manager
            CatJonne Level 1

            Thanks for advice!

             

            What do you mean by “try moving a topic”? The topics are also in the root. (I haven’t found this a problem since we only have 13 topics. But my plan was to move the images to a separate folder when all images were replaced. This seemed to be the fastest way to get started and fast getting a lot done.) Whit this in mind, do you think that creating a folder in Rh and moving the topics to it can result in the images showing in Project Manager?

             

            I have made a backup and will start with deleting the CPD file and reopening Rh.

             

            If this won’t do the trick I will create a folder in the Images “folder” in Rh and move one image I see in Rh to it. Then I will move one image (not visible in Project Manager) in Windows Explorer to the folder too see what happens.

            • 3. Re: Images are missing in Project Manager
              Peter Grainge Adobe Community Professional (Moderator)

              Create a folder and move a topic. What I hoping is that it will force Rh to update not just the location of the topic but also the missing image.

               

              13 topics is a small number so leaving them in the root wouldn't normally be an issue, it just removes the opportunity to use the folder renaming fix.

               


              See www.grainge.org for RoboHelp and Authoring tips

               

               

              @petergrainge

              1 person found this helpful
              • 4. Re: Images are missing in Project Manager
                CatJonne Level 1

                Yes!

                I think my problem is solved by deleting the CPD-file.

                 

                I did this:

                • Made an back-up
                • Saved reports from Rh (Images, Used files, Unused files)
                • When Rh was closed I deleted the CPD-file
                • Opened Rh
                • Generated new reports and compared them to the old ones.
                • Now there are 47 more images in the report Used files.

                 

                 

                Since I don´t use all of the 154 images (saved in the project folder in Windows Explorer) I’m not sure that this is every image that was missing. I guess the only way to be sure that all images that should be shown in Project Manger really are there is to search, in Design view, all the images listed as unused?

                 

                Thanks for the help and happy holidays!

                • 5. Re: Images are missing in Project Manager
                  Peter Grainge Adobe Community Professional (Moderator)

                  Visit www.wvanweelden.eu. Willam has a script to remove the images that are unused.

                   


                  See www.grainge.org for RoboHelp and Authoring tips

                   

                   

                  @petergrainge

                  • 6. Re: Images are missing in Project Manager
                    CatJonne Level 1

                    Thanks for the tip.

                     

                    Does anyone know if the script will remove all images listed in the report “Unused files” even though some images are actually used? (Asking since I had problem with images being used but not shown in Project Manager and thus reported as unused files.)

                    • 7. Re: Images are missing in Project Manager
                      Willam van Weelden Adobe Community Professional & MVP

                      The script checks whether RoboHelp reports an image to be used. But this

                      does differ a bit from what the unused files report shows you (go

                      figure). Every file that RoboHelp recognizes as being in use somewhere

                      is retained.

                       

                      The script also has a mode to only list images to be deleted. Run that

                      first before actually deleting the images.

                       

                      Kind regards,

                       

                      Willam

                      • 8. Re: Images are missing in Project Manager
                        CatJonne Level 1

                        Great! Thank you so much. I will try this in due time.