1 Reply Latest reply on Dec 28, 2013 8:43 AM by Mike M

    Flash Update

    Kendrick004

      I trying to update my flash player. I am sent to the update internet explorer and when I do that, I get a message saying that Adobe flash player has already been updated. Shockwave is enabled, ActiveX is disabled so what else do I need to do? I also tried checking for new updates but nothing happend. Can you please help me.

        • 1. Re: Flash Update
          Mike M Level 6

          I can only assume (since you didn't specify) that you're running WIndows 8 or 8.1 and IE11. Flash Player for IE is embedded by Microsoft with Windows 8, & 8.1 and you CAN'T update it here. it ONLY updates through Windows Update.

          This is a really common problem ("You need to install Flash Player" messages, when you HAVE it installed) with 8, 8.1 and IE11 which Microsoft has been aware of since October 18 when they released their latest "untested" browser. The pages can't recognize the browser, so they don't recognize any of the plugins, like Flash Player. So far, Microsoft has made NO indication that they have any plan to fix it soon.

          Microsoft's recommendation is to use Compatibility View for affected pages, and "pretend" you're using an different browser. Trouble with that is it has seen limited success at best, and you have to individually enable it for EVERY page that has problems.

          I'm not big on "pretending" so I recommend actually using another browser.

          Firefox (from Mozilla)

          Opera (from Opera)

          Safari (from Apple)

          Chrome (from Google)

          ANY of those will work where IE11 won't, with the Flash Player Plug-in (For all other browsers), and Chrome doesn't even need that because it has its own Flash Player plugin built in.