3 Replies Latest reply on Dec 29, 2013 9:58 AM by the_wine_snob

    Unbelievable usability issues

    Wilf7994@gmail.com

      hi all

      The usability issues I am encountering are so basic that I do not want to create video with this sw. Having used Premiere pro in the past I know the typical quality of Adobe sw and I simply can't believe they connect their name with this product. Either that or it is something on my PC that I urgently need somebody to tell me about - before I forever close the books on this one.

      A few things:

      * When loading an avi clip into a new project, Drag the clip from some explorer window to the timeline and 1 out of 6 times, it does not appear on the timeline. It is not shown but it's there .... And f*cks up whatever else you drag to the time line next. You end up with split clips, dupicated clips, ...

      * Having edited the timeline a bit, remove all the clips from it, then import a new short clip. You'd expect it to end up under the cursor but alas you often have to scroll to it: it often is way out of view w.r.t. the current horizontal timeposition or (see above) apparently gone.

      * when you add or cut a piece from the start or end of any clip in your tmeline, the In and Out points ALT-[ and ALT-] on the timeline do not move accordingly - useless !

      *  When adding clips, removing clips, shorting etc the horizontal position craps up time and again - with nearly every significant edit you need to manually reposition - useless.

      * This one is the worst: When dragging on the start or end of a clip in the timeline, it lets you drag, then pretends you never unclicked. the clip just apears to drag wherever you take the cursor - UNBELIEVABLE. You have to click elsewhere then select another clip in order to stop changing the size of the current clip and god knows what it's done to the clip I tried to edit when I succeed to stop dragging. With this bug you cannot call it a video editor !!!!

      * There's more but before ranting on let's see if there arrives any reply to this cry for help.

       

      It is only this program that does this on my one year old IntelC7 PC. It shows the same bugs on my W8.1 laptop. All other stuff on my W8 PC has been running nicely including Photoshop elements BTW - which shows no usability or quality issues. Video imported is typically uncompressed DV-Avi or standard mpeg: I did perform 'Updates' and am running build 20120901, B261, 425551.  I am sw development manager with 25+ years experience working on commercial products and have worked as video editor for 2 local TV stations as a hobby, so not quite a rookie. This product as is would not even be considered worthy of alpha-testing where I work.

      and yet .... not a cry or complaint about this on internet anywhere ...Am I stupid or what ?

        • 1. Re: Unbelievable usability issues
          Steve Grisetti Adobe Community Professional

          You definitely do have a learning curve. And there are likely some issues on your computer. But with this many issues, I'm not sure where to even begin.

           

          It might be worth considering a different program that more closely fits your workflow. Have you considered or tried a program like Sony Movie Studio or Pinnacle Studio? Might be worth downloading a free trial of each and giving them a test drive.

          • 2. Re: Unbelievable usability issues
            Wilf7994@gmail.com Level 1

            Thanks for your answer, Steve,

             

            No doubt I have a learning curve but it should not include what are obvious bugs.

             

            What really surprises me is that nobody seems to experience my issues, which to be frank

             

            make this sw imho completely unworkable. Yet the type of usability  problems do not suggest operatingsys or hw dependency: I consider them typical of junior programmer errors. BTW: I am also quite familiar with Pinnacle (9, 10 and 14) - they seem to have ironed out the bugs over the years but are nowhere near sophisticated enough  when making even simple L -or J-cuts. let alone more complex edits.

             

            I do want to use PE11 and don't mind learning curve (although it does not seem as hard as you seem to suggest). Any tips on PE11 are welcome. Any chance you suggesting specifics regarding ‘issues on my computer’? (I can't see them).

             

             

            Groetn

            Wil

             

             

            Van: Steve Grisetti

            Verzonden: 29-dec-13 18:01

            Aan: Wilf7994@gmail.com

            Onderwerp: Unbelievable usability issues

             

             

             

             

             

            Re: Unbelievable usability issues

            created by Steve Grisetti in Premiere Elements - View the full discussion 

             

             

             

            You definitely do have a learning curve. And there are likely some issues on your computer. But with this many issues, I'm not sure where to even begin.

             

             

             

            It might be worth considering a different program that more closely fits your workflow. Have you considered or tried a program like Sony Movie Studio or Pinnacle Studio? Might be worth downloading a free trial of each and giving them a test drive.

             

             

            Please note that the Adobe Forums do not accept email attachments. If you want to embed a screen image in your message please visit the thread in the forum to embed the image at http://forums.adobe.com/message/5963767#5963767

             

            Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page: http://forums.adobe.com/message/5963767#5963767

             

            To unsubscribe from this thread, please visit the message page at http://forums.adobe.com/message/5963767#5963767. In the Actions box on the right, click the Stop Email Notifications link.

             

            Start a new discussion in Premiere Elements at Adobe Community

             

            For more information about maintaining your forum email notifications please go to http://forums.adobe.com/thread/416458?tstart=0.

            • 3. Re: Unbelievable usability issues
              the_wine_snob Level 9

              Wil,

               

              Looking only at the Clip "sticking" to the Cursor, I would look into two drivers, to try and iron that one out: first the video driver - is your video driver the latest for your card/chip, from the nVidia, or AMD/ATI Web site? Next, the mouse driver. What mouse are you using, and on which OS version, and what is the number and date of that mouse driver?

               

              That would be a good starting point.

               

              Good luck,

               

              Hunt