17 Replies Latest reply on Jan 10, 2014 12:19 PM by jamesfarmer007

    Connecting Sony Reader

    Terry@NZ

      As I understand it, to connect my Sony Reader to Adobe Digital Solutions, I must sign in to Sony and to Adobe wih the same User Name and password. BUT Adobe requires an email address for a User Name and Sony requires no special characters.

       

      What to do?

       

      Terry@NZ

        • 1. Re: Connecting Sony Reader
          sjpt Level 4

          I have Sony reader working fine with no Sony login at all.

           

          You must install the Sony Reader software for the Sony ereader device to show up under ADE (digital editions).

          You don't need ever to run this if you don't want to, it just installs extra software used by ADE.

          Not sure why Sony makes this awkward step, other ereaders don't.

           

          You then authorize ADE with your Adobe ID; using email and password   (menu/Help/Authorize Computer, Library/Authorize Computer on older more reliable v1.7.2)

          There is a bug in ADE that means special characters are not accepted in the password (no sensible error message issued),

          so if you have them you must login to the Adobe website and choose a weaker password.

           

          You then authorize the Sony from ADE  (menu/Help/Authorize Device, Library/Authorize Device on v1.7.2)

           

          There is a bug in ADE2.0/2.0.1 that means it will not work with the Sony and Overdrive library books.

          If you want to use the Sony with library books, use ADE v1.7.2.

          You can use both v2.0/2.0.1 and v1.7.2 together if you need the extra features of V2 (vendor ID and screen reader support).

           

          ~~~~~~~~~

          There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

          (You can have them both installed at once if you like.)

          Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

          http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

          The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

           

           

          Some people have found ADE trying to upgrade automatically. 

          It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

          Probably best to say no if 2.0.x installation asks if you want to migrate your library.

          • 2. Re: Connecting Sony Reader
            Terry@NZ Level 1

            Thanks, sjpt,

            I appreciate your time and the clear instructions.

             

            I have downloaded and installed the Sony Reader (it works).

             

            Uninstalled Adobe Digital Editions v2 and installed v. 17.2.1131 - I want to use Overdrive library books.

             

            Library/ Authorize Comuter tells me it is already authorized.

             

            There is no Library/Authorize Device.

             

            ADE will play my Overdrive library book. But of course there is no interaction between the computer and the Sony device.

             

            What next?

             

            Terry@NZ

            • 3. Re: Connecting Sony Reader
              Terry@NZ Level 1

              PS

              I downgraded the Adobe password.

              ADE seemed not to recognise this.

              If this is relevant.

               

              Terry@NZ

              • 4. Re: Connecting Sony Reader
                sjpt Level 4

                Sometimes ADE (both 1.7.2 and 2 can suffer) gets confused authorization.

                Try ctrl-shift-D to deauthorize the computer on 1.7.2, restart ADE and reauthorize the compter (more details at bottom).

                 

                What sort of a Sony ereader is it?

                I think it probably needs to be connected via USB to use with ADE, even it it is a wireless one.

                (I've got an old PRS-350 with no wireless).

                • 5. Re: Connecting Sony Reader
                  jamesfarmer007

                  Has anyone got an answer to this as just wasted 2 hours 40 mins of my life with the idiots at Adobe and no futher forwards my Ereader is not recognised by Adobe Digital Eds -  I have a PRS 350

                  • 6. Re: Connecting Sony Reader
                    sjpt Level 4

                    Have you installed Sony Reader, as in post 1 above?

                    • 7. Re: Connecting Sony Reader
                      jamesfarmer007 Level 1

                      Yep have that installed

                      • 8. Re: Connecting Sony Reader
                        sjpt Level 4

                        Also, you must turn on the Sony.

                        Not obvious as it says 'charging' or somthing similar even if you don't.

                         

                        Sony should say something like 'connected', and should show up in file manager (Windows Explorer, Mac Finder) as a mounted drive.

                        If it doesn't, try a different USB socket or different cable.

                         

                        If you want library books on the Sony (same as mine, old but very neat),

                        install ADE v1.7.2 as one of the many bugs in ADE2.0/2.0.1 makes them fail when used with Sony+Overdrive.

                        • 9. Re: Connecting Sony Reader
                          jamesfarmer007 Level 1

                          Have tried that as well

                          • 10. Re: Connecting Sony Reader
                            sjpt Level 4

                            Can't think of anything else for now.

                            Only issues I have had over a year or so with two PRS-350s are the ADE2 bugs and forgetting to turn it on.

                             

                            Just confirming, does yours show up in File Manager or not?

                            • 11. Re: Connecting Sony Reader
                              jamesfarmer007 Level 1

                              Mine shows up on my PC fine no problem what so ever and will be viewed in Sony Reader store. Adobe told me to contact Sony and Sony have told me to contact Adobe so I'm caught between the two

                              • 12. Re: Connecting Sony Reader
                                sjpt Level 4

                                Not sure why it doesn't show up in ADE, but it doesn't matter too much.

                                You can copy books from computer to Sony using file manager,

                                and as long as you have got the Sony correctly authorized (which I think you can do via Sony Reader?) you will be able to read them on the Sony.

                                That is a slightly irritating extra step, but that is what I did when using ADE2.0/Sony with library books, before I realized 1.7.2 resolve that particular issue.

                                 

                                Might be worth trying a factory reset of the Sony.  Back up any books on it first.

                                • 13. Re: Connecting Sony Reader
                                  jamesfarmer007 Level 1

                                  After spending three hours on a live we chat and trying all that I've had it well and truly I've just binned my Ereader.

                                  • 14. Re: Connecting Sony Reader
                                    jamesfarmer007 Level 1

                                    Thanks for your help by the way

                                    • 15. Re: Connecting Sony Reader
                                      jamesfarmer007 Level 1

                                      I fixed it in the end using this link and the option saying repair

                                       

                                      http://www.sony.co.uk/support/en/product/PRS-350/updates

                                      • 16. Re: Connecting Sony Reader
                                        sjpt Level 4

                                        Glad you got it fixed.

                                         

                                        When I follow that like the only 'repair' I see points at a real hardware repair:

                                        apart from anything else you couldn't have done that in the time.

                                        • 17. Re: Connecting Sony Reader
                                          jamesfarmer007 Level 1

                                          Thought it was worth a go.  I did a bit of digging as Adobr couldn't help me at all.

                                           

                                          I unplugged the device, did the update/repair option, restarted the laptop, plugged back in and uninstalled ADE 2.0 Hey presto working all ok now