1 Reply Latest reply on Jan 3, 2014 5:26 PM by Mike M

    Plugins for Flash Player

    patrickburns57

      I have latest flash player installed but note also have Flash Player 11 plugin 64 -bit installed from 2012, do i need this?