4 Replies Latest reply on Jan 9, 2014 1:42 PM by heyheyhey

    Error Code "E_ADEPT_REQUEST_EXPIRED" when authorizing

    VCarroll

      I am trying to help someone use ADE 2.0.1 for library books.  The first time we installed the program and tried to authorize the computer with their Adobe ID and password, it returned the "E_ADEPT_REQUEST_EXPIRED" error code.

       

      Seeing the cause of this problem in other forums, I checked the date/time/zone on the computer, which is running WIndows 7.  It was set to the incorrect time zone, so we reset to the proper time zone, restarted the computer, and then readjusted the time to be correct.

       

      Unfortunately, this did not resolve the issue, and further attempts to authorize the computer returned the same "E_ADEPT_REQUEST_EXPIRED" error code; uninstalling and reinstalling Adobe ADE 2.0.1 after fixing the time zone and time resulted in the same error code upon attempts to authorize.  Changing the password at adobe.com did not work either.

       

      I am unsure of what to do at this point--everything I've read says the "E_ADEPT_REQUEST_EXPIRED" error code means you need to fix the date/time/zone on the computer, which we have done.  After multiple restarts and reinstallations, why are we still getting this same error message, and what can we do to properly authorize ADE with an Adobe ID?

       

      Help much appreciated.

        • 1. Re: Error Code "E_ADEPT_REQUEST_EXPIRED" when authorizing
          sjpt Level 4

          Are you 100% certain that the "E_ADEPT_REQUEST_EXPIRED" message is coming from authorization, and not from an attempt to access a book?

           

          One thing you could try, not at all convinced it will work though ...

          ~~~~~

          Sometimes ADE gets its registration/activation confused and in a semi-authorized state.

          Uninstalling and reinstalling does not help, and indeed installation can even trigger this state.

          Unfortunately, it often then gives misleading error messages about what is wrong.

          A common incorrect message informs you that the ID is already in use on another computer and cannot be reused.

          Another is  "E_AUTH_NOT_READY"

           

           

          This can often be resolved by completely removing any authorization using ctrl-shift-D to the Library screen on ADE (cmd-shift-D if on Mac).

          Restart ADE, and then reauthorize with your (old) Adobe ID.

           

           

          In extreme cases on the mac, the following extra step has helped some people.  Navigate to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash. If you are using 10.7, see Access hidden user library files | Mac OS 10.7 Lion. http://forums.adobe.com/thread/1265248?tstart=0

          • 2. Re: Error Code "E_ADEPT_REQUEST_EXPIRED" when authorizing
            VCarroll Level 1

            Yes, I am certain that the error occured during the authorization process (we hadn't even downloaded any books yet).

             

            I tried removing the authorization using ctrl-shift-D, but that didn't work either.

             

            I will try adjusting the time/date/zone settings again...

             

            Would you recommend installing an older version of the software?

            • 3. Re: Error Code "E_ADEPT_REQUEST_EXPIRED" when authorizing
              sjpt Level 4

              I tried removing the authorization using ctrl-shift-D, but that didn't work either.

              Do you mean it didn't deauthorize, or that after deauthorizing you still couldn't authorize?

              If the first, you must be in Library view for it to work.

               

              Would you recommend installing an older version of the software?

              Yes, I'd certainly give it a try ~ you may have seen in other posts I often suggest it.

              I hope it works for you in this case ....

               

              Just in case you haven't seen the download details ...

              ~~~~~~~~~

              There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

              (You can have them both installed at once if you like.)

              Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

              http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

              The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

               

               

              Some people have found ADE trying to upgrade automatically. 

              It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

              Probably best to say no if 2.0.x installation asks if you want to migrate your library.

              • 4. Re: Error Code "E_ADEPT_REQUEST_EXPIRED" when authorizing
                heyheyhey

                I work for a publishing company that uses ADE, and in my experience, this error message is NOT generated due to a timezone issue. It's sort of unbelievable to me that this is Adobe's official diagnonsis. When our customers get this message, it's almost ALWAYS because they clicked the download link prior to installing Adobe Digital Editions.I confirmed this with an Adobe rep using the help chat as well. It seems to be a pretty fundamental flaw with the program in general, and the Adobe rep told us that there's now way around that. It's also ridiculous, because we end up having to send our customers a new file, and Adobe is essentially charging us twice for the book.