2 Replies Latest reply on Jan 13, 2014 10:43 AM by MadamePanda

    Getting "Could not complete your request" error all the time

    RobHes Level 1

      Whenever I try to do anything in Fireworks CS6 (CC desktop version) I get the error message "Could not complete your request. An error occurred".  The only exception is when I try to preview an image I get "Could not render the database. An error occurred"


      This literally happens with any action, from opening a file to changing any attribute of an object (e.g. colour, position, size).  Try to draw a new object - same error.  Delete one - same error.


      Weirdly it does seem to complete the action after I "Ok" the error message.


      Any ideas? 


      I am running this on Mac OSX 10.9.1 on a pretty new MacBook Pro.  I've checked for updates and I'm running the latest version.  (I'm running the trial version, as I am trying to decide whether or not to switch over to CC from my desktop apps, but I would hope it is the same as the full commercial version)

        • 1. Re: Getting "Could not complete your request" error all the time
          Herbert2001 Level 4

          Fireworks is dead in the water, unfortunately. Support on this forum has been waning a lot as well, which only goes to show that it is probably a good idea to switch to other web prototyping software.


          For Mac you have Sketch.


          Otherwise, check if there are any issues with your installed fonts. It might also have something to do with Mavericks - people have been complaining about similar issues here and there on the forum.

          • 2. Re: Getting "Could not complete your request" error all the time

            For me the Fireworks stopped when it got to "Intializing Tab Windows", then a crashed and  displayed "Could not complete your request. an error occurred" and would never load. Basically dead. I couldn't use it at all. My whole workfow came to a stand still.Fireworks-Error.jpg



            Just before this happened, I was trying a new feature from within Dreamweaver. While inside Dreamweaver, I could double-click an image file and it opened in my Fireworks to be edited. I thought . . . Wow, this is really cool. I edited that image and closed it and continued on my work. Since then, that "Connection" between applications has become permanent. Fireworks "THINKS" it is still connected to Dreamweaver. Later Fireworks would NOT open/load at. I would always get the above error.



            BTW: I had to do this twice, because the first time, I missed a file somewhere.


            I had to completely uninstall all ADOBE applications. I mean everything! I had CS3 & CS4 and Adobe Readers on my system.


            Since I'm on the mac, I went through the "Application Support" both user and system and the "Preferences" for both user and system and deleted everything that had either "adobe" or "macromedia" in it. There was also a file in the "Launch Agent & Daemons".


            I emptied the trash and did a power off restart. Then I reinstalled CS6. Now Fireworks at least loads and I can use it again, but it still isn't the same.



            Fireworks and Dreamweaver are still "Connected". It won't save an existing PNG file as itself, it displays an error, "That file is open in another application", which is NOT true. I have to use the "Save As" option, and use the Finder to rename that file. I also notice an extra file labeled ex:0000056 which looks like the file I tried to save.


            So at least I can use my Fireworks again although it is irritating. I don't know how to "CUT" the connection between applications. Uninstalling & reinstalling did NOT reset this, the only option left would be a backup, wipe and fresh install of my entire laptop. I just don't have time to do that right now. Hope that helps someone else.