5 Replies Latest reply on Aug 9, 2006 9:33 PM by l_andrew_l

    loadMovieNum doesn't work in Projectors?!

    l_andrew_l
      I have a major project that runs off a CD, and loads other SWFs in from a projector. The projector is a small file that loads the main movie in using loadMovieNum.... the problem is that it doesn't work on some machines!

      It works fine on mine and 2 others, but at least 3 other people have told me that it just comes up with a blank screen! I have narrowed it down and it is DEFINITELY the loadMovieNum... this is a MAJOR problem for me!

      Can someone help please?!
        • 1. Re: loadMovieNum doesn't work in Projectors?!
          Rothrock Level 5
          Well obviously it works sometimes in projectors. And it should always work.

          This sounds like a strange thing that I've only run into once before. For some reason on older slower machines, my projector wouldn't load. The trick was to put about 5 empty frames at the beginning of my file. It was kind of a "preloader" that allowed the projector to load itself before it had to render or do anything.

          Other than that, you will need to give us some more information to try and diagnose anything more.
          • 2. Re: loadMovieNum doesn't work in Projectors?!
            l_andrew_l Level 1
            I've tried that to no avail. It's actually a pretty simple problem that can be replicated easily (provided you can find one of the offending machines.) Here is what I did:

            Have one .swf with content.... let's say "content.swf"....this can be anything - mine was just a simple static rectangle.
            Have one .exe projector created in flash... let's say "project.exe". This loads the other movie - loadMovieNum("content.swf",1)

            Both files can reside in the same folder - it makes no difference. And to answer your question, I had that idea myself, so I tried putting the "loadMovieNum()" statement about 30 frames out. Didn't affect anything.

            I have VERY few ideas about this that aren't just guessing, but I was thinking that maybe it's a bug that only affects certain machines by making them think that an .exe projector is a remote .swf? If that were the case loadMovieNum() wouldn't work for local content.

            As an interesting side note, I am working with Screenweaver (3rd party projector) which has a debug window that gives strange errors like "unable to start ActiveScript" on the offending machines. But I'm only mentioning that to be helpful... the problem described above is using the native FLASH projector with the most basic settings. Very confusing.

            If you need any more information I can provide it, but I've narrowed it down THAT far (which is pretty far I think)... I can't provide any more information about the offending machines because I don't really have any idea what it is about them that's causing this... so far 2 have been XP Home, but 1 was XP Pro. The Home Eds. were Japanese language version, but the Pro was Korean. The languages don't SEEM to be a factor, but I've only had the chance to test on a few machines so far, so I can't be sure about a pattern.
            • 3. Re: loadMovieNum doesn't work in Projectors?!
              Rothrock Level 5
              Each of the swf files and the projector itself should start after a few frames. And in my experience the lag isn't directly tied to the loadMovieNum. So there should be nothing – no code no art – on those first 5 frames.

              Other than that, there is nothing I know of that would be causing that. Sorry I can't provide anything more. Good luck.
              • 4. Re: loadMovieNum doesn't work in Projectors?!
                Level 7
                Copy all the files onto the harddrive of the machines your having problems
                with.

                Does this work ?

                If so then its a CD cache problem.

                Read this

                http://flashjester.com/?section=faq&cPath=14_23#88

                and make sure you don't have the loadmovie command on the first frame, put
                it on the 5th or after this.

                Regards
                FlashJester Support Team
                e. - support@flashjester.com
                w. - http://www.flashjester.com

                There is a very fine line between "hobby" and
                "mental illness."



                • 5. Re: loadMovieNum doesn't work in Projectors?!
                  l_andrew_l Level 1
                  I've found the answer! It's actually quite simple, but it took forever to troubleshoot.

                  Apparently the Flash projector can only process English filepaths. If ANY part of the path contains a non-English character (presumably non-ASCII), the Projector will FAIL TO LOAD EXTERNAL ASSETS!

                  This is what lead to the erratic behavior. Everyone who was able to view my project unzipped the files to "My Documents" (written in English on Japanese windows), but for everyone that unzipped to the "Desktop" (written in Japanese characters, it would fail to play.

                  Please make a note if this, as this is a MAJOR bug in the Flash projector that affects ANYONE with an international target audience!