0 Replies Latest reply on Jan 9, 2014 1:49 PM by ristenk82

    Edge Animate files not working in CMS

    ristenk82

      I published my edge animate project. I'm using a CMS called Composica and it doesn't support .OAM files but I can put html files into a page with an iframe that calls javascript. I have done it on html and js files that were not produced by Edge and it works fine. But when I try to put the edge html file and three supporting .js files it does not work.

       

      This particular CMS has all of the files located together so I changed the pathing for the following:

       

      1. Changed location of images file path in edge.js document because images in Composica
      are not in a seperate folder but in the same folder as the files that are calling the pics:

      im='images/'    >    im=''

       

       

      2. Change file path of the two jquery library docs in edgePreload.js:

          { load: "edge_includes/jquery-1.7.1.min.js"}    >     { load: "jquery-1.7.1.min.js"}
          { load: "edge_includes/edge.2.0.1.min.js"}      >     { load: "edge.2.0.1.min.js"}

       

       

       

      So unless their is something I am overlooking I believe all of the files have the correct path. So then I took a javascript alert and tried it in different locations to see what is not working. The html page is working and calls the edgePreload.js page correctly. But when I place the alert on the last two javascript files (edge.js, and edgeActions.js) it is obvious that this is what is not being called correctly. On the edgePreload.js file I tried the alert in these locations:

       

      // tried alert here and was successful!
         aLoader = [
        

          { load: "jquery-1.7.1.min.js"},
          { load: "edge.2.0.1.min.js"},
                { load: "coachingEssentialsTug_edge.js"},
                { load: "coachingEssentialsTug_edgeActions.js"}];
        
      // tried alert here and was successful!
              //alert("Hello! I am an alert box!!");

       

      When I tried the alert inside the aLoader I got nothing... so for some reason it is this very spot that is not allowing me to successfully connect to those two javascript files.

       

      Please any suggestions would be appreciated!