6 Replies Latest reply on Jan 12, 2014 7:06 AM by myDavey

    InDi CS6 not saving prefs

    myDavey Level 1

      Hi

      All of a sudden my InDesign is not saving my prefs

      I set/change prefs with all documents closed but still when reopen Indesign, all prefs are reset.

      I did have to reset my prefs about a week ago, but I am not sure if thats when it started...

      I use in-tools preference manager script to restore my prefs... but its driving me crazy to have to do it each time InDi opens!!

       

       

      If anyone can help me with this I would really appreciate it

       

      Thanks

      Davey

        • 1. Re: InDi CS6 not saving prefs
          Cari Jansen Adobe Community Professional

           

          Cari

          • 2. Re: InDi CS6 not saving prefs
            myDavey Level 1

            Hi Cari

            Thanks for your response

             

            • Prefs and caches were both cleared
            • All those folders have read/write permissions to the system - to others only read (But it doesnt seem to me that it would need to be read/write to all since all the library folders are only to system)
            • Regarding 3rd party plugins, I am not sure how I would do that. I should just drag their folders out of the Applications/Indesgin/Plugins folder?

             

             

            Thanks

            Davey

            • 3. Re: InDi CS6 not saving prefs
              Cari Jansen Adobe Community Professional

              Quit InDesign.

               

              Then:

              • Launch Adobe Extension Manager
              • Select InDesign
              • Deselect extensions that don't list 'Adobe Systems' as Author.

               

              Or

              • In your Applications or Program s folder find: InDesign folder
              • Create a folder called Plug-ins DIsabled (or something of that nature)
              • From the Plug-Ins folder drag any thrid party plug-ins to Plug-Ins Disabled folder.

               

              Relaunch InDesign, and see if things work OK now.

               

              If all of that doesn't work and you're on a Mac:

              • Quit all applications
              • Launch Applications > Utilities > Disk Utitlity
              • Select your Hard Drive on left
              • Click Verify Disk Permissions if there are errors then
              • Repair Disk Permisions

               

              Reboot your computer, relaunch InDesign and see if that works.

              • 4. Re: InDi CS6 not saving prefs
                myDavey Level 1

                Hi Cari

                Thanks for your extensive detailed help

                However, sad enough, all this did not help!

                 

                I dont know if this would help, but its worth a try:

                I started noticing this issue after A Mac Technical support agent made me do the following:

                • Enable root user
                • delete all caches
                • delete preferences
                • delete LaunchAgents
                • delete LaunchDaemons

                 

                I cant say that I know for sure that one has to do with the other, but just in case.

                However, all of the Mac experts advice didnt help that issue, so I put back all my prefs and caches etc and it is still not working properly

                 

                 

                Again, Thanks!

                And, if anyone can offer any other help I would greatly appreciate it

                Davey

                • 5. Re: InDi CS6 not saving prefs
                  Cari Jansen Adobe Community Professional

                  hi Davey,

                   

                  Have you run Utilities > Disk Utility and tried 'Verifying Permissions' ... what comes up? If there are errors, click 'Repare Permissions'.

                   

                  If that doesn't work try the following...

                   

                  Create a new user account on your computer:

                  • Open System Preferences and Click Users & Groups.
                  • Click the lock to make changes (you'll be prompted for your password)
                  • Under Login Options, click the +
                  • and Create a New User Account.
                  • Set New Account to: 'Administrator', and fillin the rest of the fields, click Create User.

                   

                  Now please Log-out of your current user account and log-in with the new account:

                  • Apple menu > Log Out [username]
                  • Launch InDesign and try to change some preferences, then close InDesign.
                  • Relaunch InDesign and see if the preferences are retained.
                  • Now try and create a new document, and change some document specific preferences, and save document, and close InDesign.
                  • Relaunch InDesign.

                   

                  Are the preferences retained?

                  IF they are, then there is something not quite right on your present user-account.

                   

                  If you are 'daring' enough on your current log-in -- and this is a 'at your own risk comment ;-) :

                  • /Users/[username]/Library/Preferences  Rename the 'Adobe' folder in her 'Adobe.old' and rename the 'Adobe InDesign' folder 'Adobe InDesign.old'.
                  • Still in preferences... scroll down to com.adobe.InDesign.plist and rename 'old.com.adobe.InDesign.plist'.

                   

                  If this still doesn't fix things...  and this is also an 'at your own risk' thing to do - I'd suggest you do this with the help of a Mac expert.

                  • Rename the entire Preferences folder  Preferences.old

                   

                  To learn about which preferences are document vs applicaiton based - Mike Rankin wrote a visual guide for InDesign prferences, that outlines which are application and document preferences (it's for CS5.5, but should be ok to work from as well) - see http://indesignsecrets.com/a-visual-guide-to-indesign-preferences.php

                  • 6. Re: InDi CS6 not saving prefs
                    myDavey Level 1

                    Hi Cari

                    Thanks again for your extensive and professional answer! (You seem to be a Mac expert yourself!)

                     

                    After reading your post, before even doing anything, it dawned on me that maybe InDesign is reading prefs from 2 different places.

                    The Mac expert had told me to rename the preferences folder to Preferences Old - not specifying exactly how, so I named it "Preferences_Old".

                    I removed that folder and everything now works!!!

                    It seems that InDeisgn just looks for a Preferences folder, no matter of there is a suffix to it!! (Sounds unprofessional!)

                     

                    Anyway, Thanks again for all your help - it at least led me into the right direction.

                     

                    All the best

                    Davey

                     

                     

                    P.S. Thanks for that link - I was wondering that for a while!