1 Reply Latest reply on Jan 10, 2014 12:18 PM by sjpt

    Unable to open library books on Kobo Touch

    Nancy Toppings

      I am unable to open library books which are DRM protected on my Kobo Touch. This is a new problem in the last few months. The message on my Kobo is "This document is protected by Adobe Digital Rights Management and is not currently authorized for use with your Adobe ID. Please sign in with the authorized Adobe ID and try again." At Kobo's suggestion I have done a factory reset of the Kobo Touch. I have also deauthorized both the computer and Kobo, and authorized them again. Still no luck. Please help! I have wasted ALOT of time on this.

        • 1. Re: Unable to open library books on Kobo Touch
          sjpt Level 4

          There seem to be lots of people have Kobo problems at the moment.

          I haven't got one so I am not sure if this will help, but read around the post below and see it it matches.

           

          possible help with Kobo issues … I haven’t tried this

          from post 23 in http://forums.adobe.com/thread/1124380?tstart=0 by Shirltaylor, Jul 26, 2013

           

           

          Also, try ADEv1.7.2.

          ~~~~~~~~~

          There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

          (You can have them both installed at once if you like.)

          Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

          http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

          The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

           

           

          Some people have found ADE trying to upgrade automatically. 

          It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

          Probably best to say no if 2.0.x installation asks if you want to migrate your library.