3 Replies Latest reply on Jan 10, 2014 4:31 PM by heathrowe

    stopping embedded video from loading multiple times

    PakoPako

      Hi,

       

      just started using Edge Animate. I have some experience with Flash and After Effect so the layout is pretty familiar to me. I have no background in coding so I am very happy that it generates codes for me.

       

      My goal is to make a simple html5 site with links / embedded videos to my contents (500 and vimeo). I copied some codes used for Youtube embedding, sub'd the url with vimeo url, and it worked fine. I used a "play video" button on the main page to trigger loading the video page (see my code below).

       

      It worked great the first time I clicked the button and went to the video page. However, upon returning to the main page, and click the "play video" button again, a duplicate copy of the video is loaded right below the video loaded upon first click. This occurs for as many times as I click the play video button.

       

      Anyone knows how to fix this?

       

      Thanks

       

      Pako

      ---------------------------------------------

      sym.play("VideoPage");

       

       

      var youtubevid = $("<iframe/>");

      sym.$("vcontainer").append(youtubevid);

       

       

      youtubevid.attr('type','text/html');

      youtubevid.attr('width','500');

      youtubevid.attr('height','375');

      youtubevid.attr('src','vimeo code');

      youtubevid.attr('frameborder','0');      

      youtubevid.attr('allowfullscreen','0');  

      -----------------------------------------------