2 Replies Latest reply on Nov 24, 2014 12:04 PM by Gnarly Tree Photography

    Photoshop CC KB/Trackpad buttons not working

    Trilo Byte Level 1

      Help!  I'm not sure if this was caused by a recent update to Photoshop, an OS update, or some other software/hardware issue.

       

      I'm using Photoshop CC 14.1.2, and running Mac OS 10.9.1.

      Mac Pro 2.26GHz Xeon, 32GB RAM, nVidia Quadro 4000, Apple Magic Trackpad input device.

       

      When I run Photoshop, I'm able to click on the menu title to see the list of options, but from there I'm unable to click on any menu item.  I'm also unable to use the keyboard to navigate (via arrow keys) or select (via Enter button).

       

      I had previously been using Photoshop CC under Mavericks without any issues, so I don't imagine that's the problem.  I've restarted via cmd-option-shift click and deleted the user preferences, I've deleted and re-installed the application, I've repaired disk permissions, I've reinstalled the current OS, and nothing seems to work.

       

      My other Adobe CC apps appear to be working normally, and I'm able to run Photoshop CC on my MacBook Pro running on the save version of OSX.  I'm at a loss for what could be causing this problem, any ideas out there for a possible fix?

        • 1. Re: Photoshop CC KB/Trackpad buttons not working
          Trilo Byte Level 1

          I've figured out the cause of the problem.  Apparently, a driver update for a 3D Connexion Space Navigator connected to the system was at fault.  The updated driver app installed a 'helper' app for some virtual numeric keypad 'feature' which in turn caused Photoshop CC to be all dead inside.  I could click on the menu title name to display the menu, but not click on any menu items or use the keyboard (though strangely, cmd-Q worked and was the only way I could exit).

           

          Going into my System Preference -> User Account -> Login Items and removing the 3D Connexion app resolved the issue.

          • 2. Re: Photoshop CC KB/Trackpad buttons not working
            Gnarly Tree Photography Level 1

            Thank you so much.  I've been beating my head against the wall over this one for months now.  It's so random and the problem comes and goes on my machine.

            It was the 3D Connexion app all along.