4 Replies Latest reply on Jan 14, 2014 10:27 PM by LenoraJG

    Export Tag Ignored When Exporting to ePub

    LenoraJG

      Hello all,

       

      I am using InDesign CS6 to create a document for export to ePub. I am creating page breaks in the ePub by selecting the Split Document option in the paragraph styles. This works in every case except for my Table of Contents. The TOC is formatted using the TOC Styles. I have selected a paragraph style for the heading of my TOC that uses the Split Document option. But when I export to ePub the TOC does not start on a page by itself. Any suggestions on how to make this work?

       

      Thank you!

        • 1. Re: Export Tag Ignored When Exporting to ePub
          Ellis home Level 4

          Check the solution given by Steve Werner on this post: http://forums.adobe.com/message/5249217#5249217

          1 person found this helpful
          • 2. Re: Export Tag Ignored When Exporting to ePub
            Steve Werner Adobe Community Professional & MVP

            You're probably trying to use the paragraph style used for the title of the TOC. However, a placed TOC is a special "live" object and it's not recognized for the purpose of making an EPUB TOC.

             

            The workaround: In the TOC Style dialog, leave the "Title" field blank. Instead, create a new paragraph style to format the title, and apply it to text just above where the TOC will appear.

            • 3. Re: Export Tag Ignored When Exporting to ePub
              LenoraJG Level 1

              The solution suggested by Steve Werner surely makes sense and I tried it but it didn't work for me.

               

              I created a new text frame above the text frame in which the styled TOC appears. In that text frame I typed the title of my TOC which is simply Contents. I created a new paragraph style for the word Contents and selected the Split Document option for that para style.

               

              In the TOC Style dialog I left the Title field blank and for Style I selected "No Paragraph Style" as shown below. I updated the TOC.

               

              But when I exported to ePub the TOC header (Contents) does not appear at all and the TOC does not start on its own page.

               

              My document has three pages immediately preceding the TOC. First page is a paragraph of Acknowledgements, second page is the copyright page, third page is a poem that serves as a foreword, fourth page should be the table of contents. I have successfully used the Para Styles with the Split Document option to allow the first two pages (Acknowledgements and copyright) to be separate pages. But even after trying the workaround suggested above the poem and the TOC are placed on the same page. And I simply can't fathom why the title "Contents" does not appear at all.

               

              Any suggestions? Is there a limit to how many paragraph styles can use the Split Document option?

               

              Screen shot 2014-01-14 at 10.19.55 PM.png

              • 4. Re: Export Tag Ignored When Exporting to ePub
                LenoraJG Level 1

                Success at last! I was also using Articles to define the placement order in the ePub. I forgot to add the Contents header to the Articles panel. Once i did that all is sorted!

                 

                Thanks, Steve Werner for your workaround for the TOC Header.