0 Replies Latest reply on Jan 17, 2014 8:06 AM by SteveLogan206

    upgrade wsconfig from command line problem

    SteveLogan206

      I have 2 running sites (plus cfadmin) on an IIS 7.5 server.  I want to run the command line to use wsconfig to update the connector on the smaller production site before trying it on the larger one or all.

       

      If I run this command to get a list:

       

      wsconfig.exe -list

      There are 5 configured sites and 2 unconfigured sites

      Configured Site Number and Site Name:

        0              All

        1              Default Web Site (All)

        2              cfadmin (All)

        3              site1 (All)

        5              site2(All)

      Unconfigured Site Number and Site Name:

        4              ftp.site1

        6              ftp.site2

       

      Per the docs, to upgrade site1 it would be:

       

      wsconfig.exe -ws iis -upgrade -site "site1"   it returns

       

      The Internet Information Server (IIS) connector in site1 can not be upgraded due to the following error:

      This web server has not been configured for ColdFusion.

       

      Huh?  List shows it's configured (and CF does indeed run fine on it), but upgrade tells me it's not configured.

       

      I did also try

      wsconfig.exe -ws iis -upgrade -site 3 and got the same error.