5 Replies Latest reply on Dec 6, 2007 11:20 AM by peterfrazier

    *.zip corruption

    peterfrazier
      Thank you for providing flexbuilder free of charge.

      when using UnZip 5.52 extracting to a reiserfs i experience archive corruption errors with both $IATEMPDIR/install.dir.XXXXX/InstallerData/installer.zip AND $IATEMPDIR/install.dir.XXXXX/InstallerData/Disk1/InstData/Resource1.zip .

      when extracting installer.zip::

      error [installer.zip]: missing 75 bytes in zipfile
      (attempting to process anyway)
      error: expected central file header signature not found (file #2034).
      (please check that you have transferred or created the zipfile in the
      appropriate BINARY mode and that you have compiled UnZip properly)

      AND 'unzip -l installer.zip | grep zerog ' gives me (in part):

      0 09-27-07 15:35 com/zerog/
      0 09-27-07 15:35 com/zerog/util/

      ...with nothing else in these dirs. This may explain the error that I receive when I run: 'IATEMPDIR=/var/tmp LAX_DEBUG=1 sh /opt/ide/flexbuilder_linux_install_a1_100207.bin' erroring with:

      "========= Forking JAVA =============================================
      Exception in thread "main" java.lang.NoClassDefFoundError: com/zerog/lax/LAX"

      Where is the lax dir in the flexbuilder installer.zip archive? It doesn't seem to be included....


      when extracting Resource1.zip::

      error [Resource1.zip]: missing 2471 bytes in zipfile
      (attempting to process anyway)

      Please let me know how to resolve the aforementioned discrepancies..
        • 1. Re: *.zip corruption
          Level 7
          Use Sun JRE 1.5 in your PATH...

          May be the link helps you -
          http://codetouch.blogspot.com/2007/10/installing-flex-builder-linux-alpha.html

          ~ Arun
          • 2. Re: *.zip corruption
            peterfrazier Level 1
            Unfortunately I am still experiencing the problem... it would be very easy to solve this problem if the uncompressed files (associated with flexbuilder-linux) could be accessed via rsync (ideally) or tar'd and accessed via http. I really want to get this problem solved today, if I had access to the raw files, that could happen.... Anyway thanks for your help.
            • 3. Re: *.zip corruption
              Level 7
              >
              > Hi Peter,
              >
              Sorry for the trouble in installing FlexBuilder...

              I really dont know why you are trying to unzip the files (or may be i am
              naiive to understand that :))
              Just to quote, all you have to do is download Flexbuilder.bin file and
              download Sun JRE .... Put that in path and use the command "sh
              FlexBuilder.bin" which will launch install anywhere for you to point out
              to the eclipse directory and option to install the debug flash player. I
              did not exactly understand your problem?

              I am not sure which file did you unzip? Why are u unzipping? Nothing in
              the installer is corrupted... It looks like the procedure in which you
              are approaching to install is a bit different. If you read my link in
              the previous reply you might understand how to install.

              Or could you clearly explain what steps are you following to install the
              same (as if you are telling this to your grandma... very explicitly)

              Thanks
              Arun
              • 4. *.zip corruption
                peterfrazier Level 1
                My arch is x86_65 with 32bit kernel support and glibc support (although the 32 bit glibc should not matter because I am using static precompiled binaries). I have the jre located in /opt (the bin subdir is in the PATH, and the lib dirs are included in ld.so.conf). Eclipse is located in /opt; it too is included in the PATH. Eclipse recognizes the jre (as seen in > window > preferences > java >....). So the basic, pre-flexbuilder environment seems to be legit.

                From a bash shell (with the aforementioned variables defined) I run 'cd /opt && IATEMPDIR=/var/tmp LAX_DEBUG=1 sh flexbuilder_linux_install_a1_100207.bin'

                I receive debugging output; and the script bails with the following error message:

                Launching installer...

                ========= VM Command Line ============================================
                options: -Djava.compiler=NONE -Xmx536870912 -Xms268435456 -Dfile.encoding=UTF-8
                CLASSPATH:/var/tmp/install.dir.1448/InstallerData:/var/tmp/install.dir.1448/InstallerData/ installer.zip:.

                ========= Forking JAVA =============================================
                Exception in thread "main" java.lang.NoClassDefFoundError: com/zerog/lax/LAX

                It is interesting to note that shell script does not sanitize the environment post crash; meaning that the trap command in the InstallAnywhere script is garbage. Anyway, because this install is bailing out do to a zerog file deficiency (directly related to InstallAnywhere), I am now dumping zerog's wonderful script and trying to install by hand. So I look at the two zipped files (included as text in the flexbuilder_linux_install_a1_100207.bin script) on of which is included in the CLASSPATH seen above (Installer.zip). So I run 'unzip -l /tmp/install.dir.1207/InstallerData/installer.zip' and I receive the errors (documented in one of my earlier postings).. I have tried to unzip installer.zip on various different filesystems (reiserfs, xfs): I receive the same errors... so this doesn't look like an fs problem. I am thinking that the program used to compress the compressed content in flexbuilder_linux_install_a1_100207.bin was an old 32bit version of UnZip; I am using a 64 bit version of UnZip... I don't know if they are compatible; they should be, but the UnZip source has been neglected for a LONG time and I have seen posts on the web suggesting that unzip has problems with large files.

                Anyway, if you could run sh flexbuilder_linux_install_a1_100207.bin and then unzip the $IATEMPDIR/install.dir.XXXX/InstallerData/installer.zip and then compress/archive it as a tar.gz or tar.bz2 I will likely be able to install this thing by hand; I loath InstallAnywhere.

                thanks
                • 5. Re: *.zip corruption
                  peterfrazier Level 1
                  When installing flexbuilder (version), make sure that the PS1 and PROMPT_COMMAND variable values do not contain any escaped characters (ie- \u , etc.). Also be mindful of the fs on which the flexbuilder.bin script is run; if it's a reiserfs mounted with the tail option then the scripts size sanity checking may be tripped up.

                  Thanks again Adobe for offering this tool at no charge.