23 Replies Latest reply: Sep 19, 2014 6:27 PM by chen_cay88 RSS

    Liquify won't save in CC

    slashpot Community Member

      Tried using the liquify command in PS CC, everything worked fine but when I went to save/exit I got an error message:

       

      "The operation could not be completed

      a write permissions error has occurred"

       

      I had no option but to hit 'cancel' and lose my adjustments. Being a big fan of Liquify this is a nightmare. Anyone else seen this? Anyone got any thoughts what might be the problem?

      While I'm here I've been finding 14.2 a bit buggy in general, I just had to shutdown because I lost all my dialogs. After using the 'crop' tool, I went to right click to bring up my brush menu only to find it empty, just the blank rectangle. I soon realised that this was the case with every dialog and drop down, including the menu bar, panels, the lot. This is the second time it's happened, not happy!!

      Fortunately I was able to use shortcuts to save & exit my files, but having to restart is a major PITA, is it just me? Thanks in advance!

       

      PS: Just remembered the mini-bridge wont work either, it just fails to load!

       

      Do I need to reinstall? cry? top myself?

       

       

       

      iMac 27"Quad core i7, 2G Gfx, 16G ram, Mavericks, Wacom Intuos tablet, high blood pressure...

       

      Message was edited by: slashpot

        • 1. Re: Liquify won't save in CC
          c.pfaffenbichler Community Member

          I would recommend reading this

          http://blogs.adobe.com/crawlspace/2012/07/photoshop-basic-troubleshooting-steps-to-fix-mos t-issues.html

           

          And to verify if GPU issues may cause this try to raise Liquify without GPU support.

          Edit: On a Mac by pressing crtl-alt when invoking the filter from the menu.

          • 2. Re: Liquify won't save in CC
            slashpot Community Member

            Thanks for the reply C.pfaffenbichler, much appreciated, and certainly a great page for troubleshooting. I went through everything but no luck, sounds like a reinstall is my only hope. Isn't there a way I can save all my settings? (fairly sure there is, just can't think where it lives) If so what settings does it save?

            • 3. Re: Liquify won't save in CC
              c.pfaffenbichler Community Member

              Check out Edit > Presets > …

              But you should probably still save your Actions, Brushes etc. manually at least once.

               

              And Preferences settings are separate from this, if I understand correctly.

              • 4. Re: Liquify won't save in CC
                c.pfaffenbichler Community Member

                Does turning off »Use Graphics Processor« in the Performance Preferences and restarting Photoshop have any bearing on the issue?

                • 5. Re: Liquify won't save in CC
                  slashpot Community Member

                  No The GL card seems not to be the culprit, doesn’t look like it wants to be found! Another thing that’s happened is that I've lost my cursors more than once, For no apparent reason the full size/crosshairs reverts to the default cursors, most of these things are fixed by a restart, but even restarting the computer doesn’t help the Liquify problem. I'm sure the answer lies somewhere in the user library folder but I'm not confident about messing about in there without guidance

                   

                  My gratitude for taking the time to try, thanks.

                  • 6. Re: Liquify won't save in CC
                    john worthington Adobe Employee

                    Have you tried checking the hard drive permissions? Use the Application/Utilities/Disk Utility and select Verify Disk Permissions.

                    • 7. Re: Liquify won't save in CC
                      slashpot Community Member

                      OK, so a few further glitches caused me to completely uninstall Photoshop & start over, which I did.

                      Nothing!!!

                       

                      Exactly the same problem! Every time I go to exit the liquify panel I get the same error message and lose all my work in liquify. This is really getting to me asI use it a lot. For some things the Puppet warp can help, but mostly it’s the smudge tool with a huge brush to reshape things, ( I illustrate birds so thers a lot of re-shaping) which destroys all my detail which has to be redone costing me hours upon hours.

                      I've tried everything above and verified all the permissions (using the Disk Util as well as the info panel).

                       

                      Still I get this:

                       

                      The operation could not be completed

                      a write permissions error has occurred"

                       

                      What is the file whose permissions I'm violating? It isn't the image file or any photoshop file as I have r&w permissions on each & every one!

                       

                      Please can someone think of something else I can try! I'll name my first-born after you!

                       

                       

                       

                       

                      He probably wont like it much, neither will his wife, but tough luck!

                      • 8. Re: Liquify won't save in CC
                        john worthington Adobe Employee

                        Sorry to hear you are still having problems. One more possibility is a problem with the Liquify preferences. I have seen cases were the file path or file has become corrupted. One user had a folder that had somehow turned into a file instead! Try checking the Library/Preferences/Adobe/Plugins/Adobe Liquify CC/Photoshop/Adobe Liquify CC Prefs. I'm not at work and going from dodgy memory so it might be slightly different. Try manually deleting the Liquify prefs. Good luck.

                        • 9. Re: Liquify won't save in CC
                          PECourtejoie CommunityMVP

                          Hello, in the past, some filters used to create rogue scratch files on other disks. Do you have other disks plugged in?

                          Did you try launching Liquify while holdings own  the ALT key, to launch it in CPU mode (way slower) but that would allow to see if it is the GPU code that poses an issue.

                           

                          Also, please post the contents of help-system info, so that we can see the specs of your machine, and some info from the GPU sniffer.

                          • 10. Re: Liquify won't save in CC
                            slashpot Community Member

                            Many thanks for the help & info guys,

                            Firstly, John, the folder you mentioned is not there. Inside the Library/Preferences/Adobe folder, there is no 'plugins' folder, only 5 other basically empty folders. I looked inside every folder but found nothing to do with 'Liquify'. In fact I searched my entire machine and found nothing, save magazines mentioning Liquify and old .msh files.

                             

                            Also PE, it seems the GPU code isnt the culprit, I did as you said and got the same (bloody frustrating) result.

                            I've attached the Sys info contents, I hope you spot something!

                            Thanks in advance for your generosity & time

                             

                            Sys inf is here:

                            https://www.dropbox.com/sh/ujjuhrdnu2keuyw/PotNTdJLfR

                             

                            PS: While I have your attention, do you have any ideas on why Mini-bridge wont open? Bridge works fine but MB just says its looking for bridge for ever & ever!

                            • 11. Re: Liquify won't save in CC
                              john worthington Adobe Employee

                              If Liquify cannot write its preferences when you OK the dialog it will cause the error you are seeing. Can you manually create the folders and save any file in the last folder?

                              • 12. Re: Liquify won't save in CC
                                PECourtejoie CommunityMVP

                                John, is it supposed to be the user's library folder?

                                Which one did you check?, slashpot?

                                Liquify was clearly slower when you launched it in CPU mode, did you notice a thin black outline?

                                • 13. Re: Liquify won't save in CC
                                  john worthington Adobe Employee

                                  PECourtejoie, yes, the users home directory. I believe all user shared application preferences should be in there. I suspect there is a problem with the folders in that path.

                                  • 14. Re: Liquify won't save in CC
                                    slashpot Community Member

                                    Thanks again for your help guysmuch obliged!

                                    John, Do you mean the Library folder inside My home folder? I have read write permissions for everything in there, including all subfolders. The user folder just has the usual folders (as shown below) Is it possible I'm missing a folder? If so what should I do?

                                     

                                    PE, no I didn’t notice anything like that, and I only drew a cople of strokes to make a random change to see if it would save, but they appeared instantly. Problem is Liquify only has one button to both save and exit, how can I save it manually?

                                     

                                    Screen Shot 2014-02-04 at 4.54.37 pm.png

                                     

                                    It's getting so I'm scared to use new features in case it crashes! AAAAaaaaaarrrrgggghhhhh!!!

                                    • 15. Re: Liquify won't save in CC
                                      PECourtejoie CommunityMVP

                                      Hello, Slashpot your library folder is hidden by default, it's the one that is greyed out in your screen capture. Open it, to find the folder John mentionned earlier, and check the ones he mentionned.

                                       

                                      If you hold down ALT as you navigate to filter>Liquify, you should see a one pixel outline at the edge of your image. That's the hint that liquify is running in CPU mode (or make a huge brush and see if you have real-time -GPU or stutters -CPU mode)

                                      • 16. Re: Liquify won't save in CC
                                        Bruhart Community Member

                                        Hi Slapshot,

                                         

                                        I had the same issue.

                                        I just created a different admin account (users&groups).

                                        And used photoshop in that account with no problem.

                                         

                                        Its related with permissions, maybe u have 2 different computers with

                                        the same username like i do.

                                         

                                        Troubleshoot User Permissions

                                        If none of the troubleshooting steps above solve your problem, it may be user permissions related. Simply using a Repair Permissions command is not always bulletproof. I highly recommend trying a new Admin user account to verify a permissions problem prior to trying to repair permissions.

                                        Once the Admin user account is created, log into the new user and run Photoshop to see if the problem goes away.

                                        • 17. Re: Liquify won't save in CC
                                          john worthington Adobe Employee

                                          slashpot, did you get you Liquify permissions problem fixed yet? If so please share your solution. Thanks.

                                          • 18. Re: Liquify won't save in CC
                                            john worthington Adobe Employee

                                            Bruhart, did you move your OS from an older Mac using the Migration Assistant? )I'm trying to locate the root cause.)

                                            • 19. Re: Liquify won't save in CC
                                              Bruhart Community Member

                                              No i didn't John.

                                              The issue was from a new computer and same username on 2 computers.

                                              I think.

                                              • 20. Re: Liquify won't save in CC
                                                john worthington Adobe Employee

                                                If you use your old (non-admin) user account now, you still get the error on exit in Liquify?

                                                • 21. Re: Liquify won't save in CC
                                                  slashpot Community Member

                                                  I still have no liquify, it costs me hours having to use the Smudge tool and then fixing all the blurred bits, occasionally Puppet warp does the job, but boy I need that filter back! I did the Admin account thing, but I think maybe I stuffed it up. I'll try again. I know how to get to the library folder and fix the permissions, and I've run Repair permissions in Disk Util a coupla times. I've also tried running in non-GPU mode, nothing works!

                                                  If I figure it out Bruhart I'll be sure & tell you the fix, and I am determined!

                                                   

                                                  Many thanks for the generous time and brainpower you guys have spent on this, it really is appreciated!

                                                  • 22. Re: Liquify won't save in CC
                                                    john worthington Adobe Employee

                                                    The official fix for the permissions problem. Update your Creative Cloud app. Quit and relaunch to update: http://helpx.adobe.com/creative-cloud/kb/creative-cloud-connection-faq .html#id_10491

                                                    • 23. Re: Liquify won't save in CC
                                                      chen_cay88 Community Member

                                                      Hey snapshot I don't know if you solved your problem yet or anybody else with the similar error. My friend had the same problem and he's not very good with computers so asked for my help. And the solution was really easy, i did what all forums said and nothing, even reseting the computer permissions booting the OS.

                                                       

                                                      what worked for his computer was this advice posted by adobe staff:

                                                      To fix the permission:

                                                      - Hold down the Alt (Option) key when using the Go menu. The user library folder is now listed below the current user's home directory. Click and open the library folder.

                                                      - Select the Preferences folder. Press command-I to get Info. Expand sharing and permssions at the bottom of the Get Info dialog. Select your user name, the one with (me) after it and make sure Read & Write privileges are set, not Read Only.

                                                      - If that folder is ok move down to the Adobe folder in Preferences and do the same check.

                                                      - If that folder is ok move down to the Plugins folder in the Adobe folder and do the same check. I suspect this is the bad one.

                                                       

                                                      The thing is that he didn't had the plugins folder mentioned above. But the adobe folder mentioned above also once i pressed COMMAND + I had the administrator rules set for READ AND WRITE, staff READ ONLY. and everyone READ ONLY. It asked me the password to alter this two options and after I changed them to READ AND WRITE, voila. Liquify and lens corrections working perfectly.

                                                       

                                                      Please let me know how it goes. Best of luck everyone