1 Reply Latest reply on Jan 28, 2014 12:46 PM by Mike M

    Flash player

    ParkKil

      Game Forge of Empires is saying i need latest version of flash player.  tried all the steps adobe recommended, still does not play.