6 Replies Latest reply on Aug 11, 2006 1:59 PM by extol

    Can't dolly.

    extol Level 1
      Has anyone else had a problem of not being able to dolly the camera with w3d models exported from 3dsmax? It will rotate and pan, but not dolly.
        • 1. Re: Can't dolly.
          Roofy Level 1
          What does your behaviour script look like. Are you using the script from the library or is this your own script. If it is your own, then I would suggest either just using the script from the library palette or look at the script from the library palette to see how it is created so that you can implement it into your script.
          • 2. Re: Can't dolly.
            extol Level 1
            Thanks for your reply, Roofy. I am using the 3D Behavior from the library. But even if I open my model in the editor and manually try to dolyl the camera, it doesn't do anything. The model is some mountain terrain. Could it be too complicated?
            • 3. Re: Can't dolly.
              Roofy Level 1
              Hi,
              I do not think the scenery is too complicated becuase either nothing would work, the system would animate to a craw, or Director would crash. However, I would not go past 13000 visable polys, meaning the amount of polys that are visable to the camera. You can check this by double clicking on the 3d member to veiw the shockwave window, and at the very bottom of the window will show how many poly's are currently visable.

              Another thing I could think of, and this is complicated to explian, is that maybe scenery scale is too big. What I mean by this is that I think Director's measure of units are in centimeters, and if you set max to be in meters, then your scene shockwave is going to be 1000 times bigger then it was in MAX. I am not saying this is a bad thing, it is just that your translation amounts might need to be bigger. So instead of the default 5 units of translation, try seeing if the camare moves with a translation of 100.
              • 4. Re: Can't dolly.
                extol Level 1
                Okay, I changed it to 100. That did make a difference. But instead of zooming in, it just makes my model disappear starting from the bottom and the rising to the top. Any suggestions?
                • 5. Re: Can't dolly.
                  Roofy Level 1
                  If I understand you correctly, it sounds like you translated on the axis of the Camera's up vector. It is important to undertand what this and the forward vector means. What this means is that it tells which way the camera or any other type of node is pointing. For example, although I do not know Max's settings, in Plasma, the camera's upvector is positive z, and the forward vector positive Y. On the other hand, Maya's camera upvector is positive Y and the forward vector is positive z. So, what does this all mean? It means that lets say you select an object in your 3d app, and you want to move it up 10 units, and lets say the camera's upvector is set to Y, then that means you are translating the selected object up 10 units on the Y axis or in Director lingo terms....

                  myObject.translate(0, 10, 0)

                  Now with this in mind, what ever the 3d application might be, when exporting, the upvector and forward vectors are exported to Director as well. So my point to this lengthy explaination is that just switch the translate axis to the opposite axis, meaning if you translated on the Y axis then translate it on the Z axis to move forward, or if you translated on the Z axis then translate it to the Y axis to move forward.
                  • 6. Re: Can't dolly.
                    extol Level 1
                    Roofy, you're a genius! That totally did the trick. I realized that I had exported my model from the FRONT viewport. I tried exporting it from the PERSPECTIVE viewport and that also worked. Anyway problem solved. Cheers to you!