5 Replies Latest reply on Jun 3, 2015 3:23 PM by floosfloos

    Projects not saving, linked to Error 33:4

    Adrian_ZA

      Hi there

       

      I wanted to find out if there's a solution to this, and point out some behaviour that might help.

       

       

       

      Basically:

       

      • When working on an After Effects project for a little while, I notice that I can't Save or Save As anymore.
      • The giveaway is that the titlebar always shows the little "unsaved work" asterisk * (for example Project1.aep*).

      • If I Save, it appears to work fine, but the asterisk doesn't go away. If I Save As (for example, ProjectBackup.aep), the titlebar remains Project.aep*. The new project has been created in the folder I saved to (so the file ProjectBackup.aep is created, and the file size looks about right), but After Effects still shows that an unsaved copy of the original file is open.

      • If I try and close AE, it asks if I want to save. If I click "Yes", the dialog box goes away, AE does not close, and the project still appears to be unsaved. I can only close AE if I click "No" when it asks to save.

      • When I eventually force AE to close, all instances of that project (the original, any versions I tried to Save As as well as any autosaves that were made) give me the following message on opening:

        "Missing data in file. (33::4)"

        ...and the file refuses to open.

       

      This has on occaision led me to lose hours (an in one case, an entire day's) worth of work.

       

       

       

      My solution so far has been to only ever use incremental saves (every 5 min or so) and to check if the * goes away in the titlebar when I do. If it doesn't, the new file is corrupt and I have to open the previous good save I made and catch up the last few minutes of work. Autosaves are useless, because they trigger this "save" bug and I end up with hundreds of corrupt autosave files.

       

      Sometimes this can happen the very first time I try and save, sometimes only hours in. But if I'm working on a project for long enough, it is guaranteed to happen sooner or later.

       

      It's really problematic, because if you don't notice that the * is still there every time you save, you might end up losing hours of work since your last decent save. If you only have one save, you're out of luck - After Effects will corrupt it as soon as this bug occurs.

       

       

       

      Things I've tried:

       

      Importing one of these "courrupt" aep files into After Effects -> doesn't work

      Rendering out one of these files in AME or Premiere -> doesn't work

       

      This happens using After Effects CS6 and CC, on both my 2011 Macbook Pro, a 2013 iMac and a Mac Pro. Haven't seen this happening on Windows, but a freelancer of mine has reported very similar circumstances on his Windows machine.

       

      My After Effects projects use lots of Illustrator files and Shape layers, if that helps.

       

       

      Anyone had this problem, or know what the solution might be?