0 Replies Latest reply on Feb 3, 2014 1:31 PM by SimeonC

    Problem with mail in CF8

    SimeonC

      Hi All.

       

      I have a problem with a CF8 install that a client has in that I cannot connect to a SMTP server to send mail through it. Description as below.

       

      Setup:

       

      Tomcat 6

      CF8.0.1

      Java 1.6.0_24

      Windows Server 2008 R2

       

      Problems:

       

      • In CFAdmin I cannot verify that the email settings are correct, even though they are. I tested the settings using telnet and sent mail fine.
      • Attempting to actually send an email with the correct settings - through cfmail attributes - gave the following error:

      "Error","scheduler-1","01/31/14","17:03:52",,"smtp"

      javax.mail.NoSuchProviderException: smtp

                at javax.mail.Session.getService(Session.java:611)

                at javax.mail.Session.getTransport(Session.java:541)

                at javax.mail.Session.getTransport(Session.java:484)

                at javax.mail.Session.getTransport(Session.java:464)

                at coldfusion.mail.MailSpooler.getConnection(MailSpooler.java:991)

                at coldfusion.mail.MailSpooler.deliver(MailSpooler.java:832)

                at coldfusion.mail.MailSpooler.sendMail(MailSpooler.java:753)

                at coldfusion.mail.MailSpooler.deliverFast(MailSpooler.java:1114)

                at coldfusion.mail.MailSpooler.run(MailSpooler.java:1024)

                at coldfusion.scheduling.ThreadPool.run(ThreadPool.java:201)

                at coldfusion.scheduling.WorkerThread.run(WorkerThread.java:71)

       

      Last time I had this problem on the server I fixed it by following the instructions here: http://www.coldfusionmuse.com/index.cfm/2012/5/4/Able-Commerce-5-on-CF--Email-Problem but this time it hasn't worked! Sadly I don't have a backup from when I fixed it last as this is our staging server on amazon which got deleted while I was on holiday and I had to rebuild it from our live server.

       

      Any help would be greatly appreciated as I'm approaching insanity on this one!!

       

      Thanks, Simeon.