17 Replies Latest reply on Feb 6, 2014 7:34 AM by didotwite

    Flash Player 12.0.0.4 will not install to Safari & Firefox OSX 10.7.5

    squidz Level 1

      I have gone through the "clean install" process posted in this forum 3 times now in an attempt to get FP 12.0.0.4 to install to Safari. I have downloaded 12.0.0.4 and run the install process. It successfully installs to Chrome but each time, Safari and Firefox again end up with 12.0.0.38! Then if I go back to the check Flash Player page: http://helpx.adobe.com/flash-player.html

       

      It will tell me 12.0.0.4 is the current verison that should be installed.

       

      If I go to Mozilla's check plugins page https://www.mozilla.org/en-US/plugincheck/

       

      It will tell me that 12.0.0.38 is installed for FF and is "up to date."

       

      So, is 12.0.0.4 only for Chrome or what?