1 Reply Latest reply on Feb 5, 2014 9:39 AM by Mike M

    Having trouble updating flash

    distortion

      I am trying to update the flash player on my computer because everything that needs the new version says "do not have the required plug-in" or some such thing.  I am using a mac, 10.6.8 with a 2.33 GHz Intel Core 2 Duo processor and Safari 5.1.10.  I go to the download page on adobe's website and hit download, but instead of downloading it just takes me to adobe's homepage.  I also tried hitting the download button on the troubleshooting page, but that didn't do anything at all.  Can anyone help me out?