3 Replies Latest reply on Feb 6, 2014 6:24 PM by carl type3

    How To Fix Jrun Crashes in ColdFusion 8

    ebcohen

      I have ColdFusion 8 running on Windows Server 2008 with IIS 7.  Lately JRun has been crashing every few minutes.  I don't know what the cause could be.  Can anyone give advice on how to fix it?

       

      The jron error I am getting in the server log mentions MSVCR100.dll and states:

       

      jrunCrash.JPG

        • 1. Re: How To Fix Jrun Crashes in ColdFusion 8
          carl type3 Level 4

          Any errors or warnings in ColdFusion8\runtime\logs\ coldfusion-event.log or coldfusion-out.log files just prior to CF8 Jrun crash?

          HTH, Carl.

          • 2. Re: How To Fix Jrun Crashes in ColdFusion 8
            ebcohen Level 1

            I don't see anything special except for "02/06 09:27:47 error There is no web application configured to service your request" but I think this is happening each time after jrun crashes.

             

            Also, I just uninstalled and reinstalled ColdFusion 8 and still get the same errors.

            • 3. Re: How To Fix Jrun Crashes in ColdFusion 8
              carl type3 Level 4

              From "OUT log" details sounds like there is a problem with the CF webserver connector.
              What do you do to overcome the outage eg restart server, restart CF or restart IIS?

               

              It would be nice to narrow down problem a bit more. Maybe there will be some interesting detail in ColdFusion8\runtime\lib\wsconfig\1\LogFiles\ jrun_iis6_wildcardYYMMDD.log file?

               

              I want to suggest delete the old connector and rebuild it using WSCONFIG.EXE tool from ColdFusion8\runtime\bin however I expect when you unintalled CF8 you likely removed the IIS connector information then the subsequent install added the connector setup information again. Maybe you can comment on how you attached CF8 to IIS?

               

              Sorry more questions than answers, Carl.