6 Replies Latest reply on Feb 6, 2014 10:47 AM by clio

    Flash won't Install

    didotwite

      Hi,

       

      Flash Player will not install on my computer. I am so frustrated, I've spent hours on this and Abode's site is very confusing. I had Flash and all was well. Then one day I did not have Flash, I do not know why. So I've been trying to install again. I follow all the steps just fine and sure enough it all goes well and I'm told Flash has successfully installed. Nope. It's not there. I go to play things (as a test) that require Flash and it says I need to download Flash. I've downloaded Flash ad nauseum. It does not 'stick.' I do restart computer after each time.

       

      I am using a MacBook Pro computer, OS version 10.7.5. I've followed the instructions on Adobe, etc... and it definitely downloads. It seems to install. It says at the end 'Installation complete.' But in the end..... nothing. Am I doing something wrong? Is something on my computer preventing this like Teflon? If so I would think I'd get a message saying so but all I'm getting is messages saying Flash has installed.

        • 1. Re: Flash won't Install
          didotwite Level 1

          Ok problem solved. All I had to do was check a box in Safari's preferences. I learned this thru a tutorial posted here by another member. If you are having this same trouble as I was having go to the security tab in Safari's preferences and check the box that says 'Allow Plug-ins'.

          • 2. Re: Flash won't Install
            pynkeye

            Well, that's good that you solved your problem!  I hear you re: your frustrations.  Such a waste of time for an often simple solution once you know it!   So between your solution and the one that worked for me, hopefully that will help many frustrated people.  I had the same thing happening to me.  Flash was working good until I tried to update and then nothing.  I tried installing several times.  I never got a message to restart computer because apparently with this installation you don't have to restart the computer, just close out the browser and as you say check off the

            "allow plug-ins" which mine was obviously already checked off.

            Oh and the reason Flash was working and then quit working was because Adobe forced everyone to update their Flash Player.

            • 3. Re: Flash won't Install
              didotwite Level 1

              Thanks Pynkeye.

               

              Yes, wish it were more obvious that 'allow plug-ins' needs to be checked. Here is the link where I learned this:

               

              http://helpx.adobe.com/flash-player/kb/enabling-flash-player-safari.html

               

              I also followed this tutorial by Mike M. http://forums.adobe.com/message/5560631#5560631

               

              Not sure if that Mike M. tutorial lead me to the first link -- that included advice to allow plug-ins -- but both mention that. I do know that the Mike M. clean install tutorial helped me properly uninstall Flash (as I'd downloaded it several times so I may've gunked up the works) and I'm afraid my own previous uninstall efforts may've lead me to delete some Photoshop things I should not have (I HOPE not!).

               

              I will say that I am quite sure (99 Percent sure) that the regular step-by-step Flash install walk-thru (which you are linked to if you go to something that needs Flash to play and you do not have it) does not say to check to see if the allow plug-ins box is checked. And of course it should. 

              • 4. Re: Flash won't Install
                clio

                My safari preferences is set to allow plug ins and I have all the same difficulty this post started with. It keeps telling me I did a successful install but it doesn't really install.

                • 5. Re: Flash won't Install
                  didotwite Level 1

                  Ouch. I feel your pain Clio. Did you do the un-install to un-install any old Flash? Just a wild guess on my part but you may as well try it if you haven't already. I used the 'clean install' tutorial for that. Here is link: 

                   

                  http://forums.adobe.com/message/5560631#5560631#5560631

                  • 6. Re: Flash won't Install
                    clio Level 1

                    Searched my hard drive for any old Flash and there wasn't any. Will try the clean install. Thank you for responding.