1 Reply Latest reply on Feb 11, 2014 1:58 AM by chiragjuneja

    Do you have an Adobe Digital Editions which is compatible with Mac Os 10.6.8?

    BennyBuddy

      Do you have an Adobe Digital Editions which is compatible with Mac Os 10.6.8? The current version which I downloaded requires 10.8 and would not work on my computer.