7 Replies Latest reply on Mar 3, 2014 6:21 AM by renegagnon79

    After Effects crashes while rendering

    renegagnon79

      Hi all,

       

      We have been experiencing regular crashes while rendering on 9 different Mac systems.

       

      We would start the render and then, all of a sudden, AE would crash.

       

      Trying to restart, AE hangs at MediaCore initializing.

       

      We actually need to do a hard shutdown to get the machine to reboot.

       

      So my question is:

       

      Could AE not release the media cache upon crashing thus blocking us to restart the app without having to reboot the machine?

       

      We are running AE in multiproc mode with 4 GB memory allocation, which actually uses 3 procs.

       

      I have tried bringing the memory allocation down to 3 GB on some of the systems, but it doesn't seems to make much difference.

       

      Finally, we do not crash every time we render. It is very random.

       

      Any ideas?

       

      Thanks,

       

      Rene

        • 1. Re: After Effects crashes while rendering
          Todd_Kopriva Level 8

          We need to know more to help you. Please provide answers to all of the questions listed here:

          http://forums.adobe.com/thread/961743

          • 2. Re: After Effects crashes while rendering
            renegagnon79 Level 1

            Hey Todd,

             

            Sorry for the late reply, answers below:

             

            • What exact version of After Effects? 12.2.0.52 but we also use CS 5.5 (mainly for the feature where you can send your camera information to C4D, something that is not in the CC version... pitty)

             

             

            • What operating system? Mac OSX 10.8.5

             

            • Tell us about your computer hardware. 2 x 6 cores CPUS, 24 Gb RAM, ATI Radeon HD 5870 GFX, 5 internal drives (4 of them are part of internal hardware raid with internal raid controller)

             

            • What versions of drivers for your graphics hardware do you have installed? No CUDA since it is ATI, 01.00.436

             

            • Do you have any third-party I/O hardware : AJA Kona 3G with either driver 1.47 or 1.49

             

            • What kind(s) of source footage? When telling about your source footage, tell us about the codecs, not just the container types. It is a combination of a bunch of them: Animation codec into .mov wrapper, tga sequences, png files, we render to uncompressed .mov files for air.

             

            • If you are getting error message(s), what is the full text of the error message(s)? No, just the beach ball of death...

             

            • What were you doing when the problem occurred? They mainly occur when rendering sequences.
            • Has this ever worked before? It is very intermittent and does not happen every day. Plus, since we are in crunch time, AE is being used 24/7, so that may not help either.

             

            • What other software are you running? C4D, Photoshop, Illustrator, both in the CC and CS6 or CS5.5

             

            • Do you have any third-party effects or codecs installed? We have sapphire and Knoll lens flare, but crashes happens if we use them or not.

             

             

            • Does the problem only happen with your final output, RAM preview, or both? Render

             

             

            • Are you using the ray-traced 3D renderer? No, we are not.

             

            • If the problem is with output, give your exact output settings (both render setting and output module settings). Unfortunately, I do not have this as our artists are working and I cannot really stop them as we have things to get out to air for early morning. I will get this info next time we have the issue.

             

            • What is the exact sequence of steps that you are taking? Just sending the render out to the queue and starting and it will either crash to desktop or stay there doing nothing.

             

            My biggest concern is why can't we just restart the app. It will always lock up while initializing MediaCore. We have our mediacaches set for 42 Gb on our main bootup drive, which is big enough to handle it. And after the crash, when we try to reboot, the machine will get to the grey Mac screen and just sit there. Have to hard shutdown the machine to have it come back up...

             

            Let me know if you need more info.

             

            Thanks,

             

            Rene

            • 3. Re: After Effects crashes while rendering
              Todd_Kopriva Level 8

              Does this happen on machines that do not have the Kona drivers? Do you have the video preview preferences set to enable output to the Kona hardware?

               

              What I'm thinking might be happening is that the 32-bit QuickTime server component (QT32 Server) is having troubles. There is a known conflict between the video preview component used in After Effects and some QuickTime components.

               

              I'm going to forward this thread to a coworker of mine who has more knowledge in that area.

               

              In the meantime, these documents may shed some light:

              http://blogs.adobe.com/aftereffects/2011/02/troubleshooting-quicktime-errors-with-after-ef fects.html

              http://helpx.adobe.com/x-productkb/multi/startup-screen-hangs-premiere-after.html

               

               

              > but we also use CS 5.5 (mainly for the feature where you can send your camera information to C4D, something that is not in the CC version... pitty)

               

              Huh?

               

              We didn't remove anything in this area. I'm pretty sure that you are referring to something that comes from a Maxon plug-in, not from anything that we make or install as part of After Effects. As such, you should be able to use the same plug-in with the current version of After Effects.

              • 4. Re: After Effects crashes while rendering
                renegagnon79 Level 1

                Does this happen on machines that do not have the Kona drivers? Do you have the video preview preferences set to enable output to the Kona hardware?

                 

                We do not have a machine that does not have the Kona hardware. They all have a Kona card and all have the video preview on in the preview preference. The artists need to work with a preview monitor all the time.

                 

                As for the Maxon thing, it may be the version of their plug-in that may not work in CC (or our artists are not aware that it should work... so no worries on that side. Thanks for letting me know that it should work in CC though)!

                 

                Thanks for your help.

                 

                Rene

                • 5. Re: After Effects crashes while rendering
                  Todd_Kopriva Level 8

                  For troubleshooting purposes, can you try disabling the video preview on a machine and seeing if the problem persists?

                   

                  I'm thinking that you may be falling victim to the issue described here:

                  http://blogs.adobe.com/aftereffects/2013/08/solutions-for-problems-with-quicktime-files-in -after-effects-cc-12-0-because-of-conflict-with-dvcprohdvideoout-quicktime-component.html

                  • 6. Re: After Effects crashes while rendering
                    Tim Kurkoski Adobe Employee

                    Rene,

                     

                    Open Activity Monitor and watch the processes while After Effects is rendering. Does any particular process get hung up, say not responding, spike in memory or process? Does the Adobe QT32 Server continue to run?

                     

                    Are there recent crash logs for After Effects or QT32 Server? Open the Console application or look in Users/<username>/Library/Logs/Diagnostic Reports.

                     

                    If this is a QuickTime related problem, go to the drive root/Library/QuickTime folder and drag all of the components from here out to the desktop. Does the problem reproduce without these?

                     

                    Does the problem go away if you disable multiprocessing? Does the problem change if you use fewer processes with more RAM allocated to each?

                    • 7. Re: After Effects crashes while rendering
                      renegagnon79 Level 1
                      Tim,

                       

                      Sorry about the belated reply.

                       

                      We have left the  systems with the original configuration after my original post and we  only got one crash for the rest of the Games, which was almost 2  weeks...

                       

                      My guess is that it was a codec issue with files created  with older version of AE. I say this because I did not get any other  crashes while rendering until the last day of the Games, Sunday Feb.  23rd...

                       

                      But I couldn't get the info that you requested as the  artist had already rebooted and was working on something else when I was  told of the crash.

                       

                      Thanks for your help,