3 Replies Latest reply on Feb 18, 2014 1:26 PM by pauldwade

    Default paragraph style when adding table rows/columns

    pauldwade

      Hi,

       

      I'm using InDesign CC and whenever I add a new table row or column the paragraph styles for those rows are defaulting to styles I don't want to use. They're actually defaulting to really big headline styles so I only have to add 3-4 rows and my table is off the page. None of the surrounding cells, columns or rows contain the styles that ID is insisting on using.


      How can I set the default style for a new table row or column?

       

      Thanks,

       

      Paul.

        • 1. Re: Default paragraph style when adding table rows/columns
          Willi Adelberger Most Valuable Participant
          1. Set up Paragraph Styles for table cells (header, corpus, etc.)
          2. Set up Cell Styles where you define the use of Paragraph Styles, I would recommend not to apply strokes and backround color in these styles.
          3. Set up a Table Style where you define the correct Cell Styles for Header, Footer, Corpus, First Column, etc.

           

          Select that style when you create or import a new table.

           

          If you want to have styles as default when you create a new document, import all styles (Text, Table, Object and Swatches) when no document is open. They will be available in every new document you create.

          • 2. Re: Default paragraph style when adding table rows/columns
            Javed_ali Adobe Employee

            InDesign for all styles follows the paradigm that what ever you set when all Documents were closed is taken to the documents that you create. When you set anything (style\attribtue etc) without any item on the page selected it automatically applies to any further item created(provided that item supports that property).

            The order of application of attributes is Application > Document > Item, with the preference being the reverse of the order.

            The problem that you are facing is that you have either set seomething to the application level (changed the style with all documents closed) or done so for a document with no item selected. If you are facing the mentioned problem for all the documents its probably done with all documents closed.

             

            What you can do now?

            1. Close all the documents and open the paragraph styles panel and change the basic paragraph style to reflect what you want.

            2. Open the cell Style panel and from its option check whether it is still using the basic pargaraph style or not.

             

            Then perform the operation that you were earlier. It should now no lomger cause any problem to you.

             

            Thanks

            Javed

            • 3. Re: Default paragraph style when adding table rows/columns
              pauldwade Level 1

              Hi, thanks for the help guys. I tried your suggestions but I still had the same problem. However I did notice that when the template documents were opened there were default styles selected in all the style panels. It looked like it was these selected default styles that were being applied to new table rows.

               

              So I opened the template documents and set all the style panels to either [None] or [Basic Paragraph], then saved the document.

               

              This has fixed the problem as no styles are now applied when rows are added.