0 Replies Latest reply: Feb 12, 2014 10:56 AM by jaw2442 RSS

    Adaptive Bitrate Issue

    jaw2442

      Hello

       

      Ok, so i've setup AMS and FME for live HDS multi-bitrate streaming.  Everything is working fine, except for the player will only play the lower bitrate stream.  When the player first starts it starts at the lower bitrate, then goes up to the highest, but only stays on the highest for a few secs, and goes back and stays on the lowest bitrate. I know the first question is about bandwidth, and there is plenty of bandwith on the player pc and server. I can also see that all 3 streams are being created in the streams folder.  There must be something im missing.  Any help is greatly appreciated. 

       

      Event.xml:

      <Event>

        <EventID>liveevent</EventID>

        <Recording>

          <FragmentDuration>4000</FragmentDuration>

          <SegmentDuration>16000</SegmentDuration>

          <DiskManagementDuration>.05</DiskManagementDuration>

        </Recording>

      </Event>

       

      Liveevent.f4m set-level manifest:

      <manifest xmlns="http://ns.adobe.com/f4m/2.0">

       

        <baseURL> http://"ServerIP"/hds-live/livepkgr/_definst_/liveevent/ </baseURL>

       

        <media href="livestream1.f4m" bitrate="150"/>

       

        <media href="livestream2.f4m" bitrate="350"/>

       

        <media href="livestream3.f4m" bitrate="700"/>

       

      </manifest>

       

      Player embed code:

      <object width='640' height='360' id='SampleMediaPlayback' name='SampleMediaPlayback' type='application/x-shockwave-flash' classid='clsid:d27cdb6e-ae6d-11cf-96b8-444553540000' ><param name='movie' value='http://"ServerIP"\videoPlayer\swfs\SampleMediaPlayback.swf' /> <param name='quality' value='high' /> <param name='bgcolor' value='#000000' /> <param name='allowfullscreen' value='true' /> <param name='flashvars' value= '&src=http://"ServerIP"/liveevent.f4m&autoHideControlBar=true&streamType=live&autoPlay=true&verbose=tru e'/><embed src='http://"ServerIP"/videoplayer/swfs/SampleMediaPlayback.swf' width='640' height='360' id='SampleMediaPlayback' quality='high' bgcolor='#000000' name='SampleMediaPlayback' allowfullscreen='true' pluginspage='http://www.adobe.com/go/getflashplayer' flashvars='&src=http://"ServerIP"/liveevent.f4m&autoHideControlBar=true&streamType=live&autoPlay=true&verbose=tru e' type='application/x-shockwave-flash'> </embed></object>

       

      Thanks