4 Replies Latest reply on Feb 20, 2014 6:22 AM by vikas.singla

    Script problems in RH 11

    MarionJD Level 1

      I'm hoping someone here knows the answer to this.  We have a number (a LOT) of projects in RoboHelp 9.  When a project  is upgraded to RH 11, the topics do not display correctly in the editing pane.  The files begin with a series of buttons with attached scripts, and, looking at the file in HTML view, we can see that the first script executes correctly, but the second one doesn't close, so the entire topic is treated as part of the script.  The two scripts begin and end correctly, but the first one begins with:

       

      </script>

      <script language="javascript" type="text/javascript">

       

      While the second one begins with:

       

      </script><script type="text/javascript">

      //<![CDATA[

      //<script type="text/javascript">

       

      I don't want to make the entire script public here, but I'm happy to send it to anyone who thinks they can help.

       

      Any idease?

       

      The files have always worked perfectly until RH 11.

        • 1. Re: Script problems in RH 11
          Willam van Weelden Adobe Community Professional & MVP

          I'm confused. The topics don't show correct in the editing pane, but a

          script is run? RH doesn't run scripts in the WYSIWYG editor.

           

          It seems that RH is commenting out parts of your script. It would be

          helpful to have a correct RH9 and an incorrect RH11 topic to compare the

          two. If you PM me, you can send those files privately.

           

          Kind regards,

           

          Willam

          • 2. Re: Script problems in RH 11
            MarionJD Level 1

            Hi William,

             

            Thank you for the offer of help. I tried to PM you with the attachments, but it only seems to want links.  Can you PM your e-mail address so I can send you the actual files?

             

            FYI, the files don't change between the two versions of RH, but in RH 11, when you look at them in Html view, the shading doesn't end when the second script does - it extends to the end of the topic, so RoboHelp treats the entire topic as part of the script, and doesn't show it in the WYSIWYG view.

            • 3. Re: Script problems in RH 11
              MarionJD Level 1

              I may have found the answer to this, in comparing documents to send to Willam.  RH11 changed </script> to <\/script> - who knows why!   It invalidated the end of the script.  With FAR, I should be able to make the replacement throughout - off to test now!

               

              Edit:  After more testing, it seems that RoboHelp 11 has changed </ to <\/ throughout the scripts, seriously messing up my files.  Didn't they test this stuff???

               

              I'll report it as a bug.

              • 4. Re: Script problems in RH 11
                vikas.singla Adobe Employee

                We have investigated the files, you have shared with us. It seems there are discrepancies in the HTML content of RH9 project as follows:

                 

                1. At the start of the topic’s HTML, “<?xml version="1.0" encoding="utf-8" ?>” isn’t valid content as compared to a standard topic created by RH9. The highlighted piece of characters, when removed, results in resolving issues with the script tag.
                2. Using proper CDATA Syntax inside the script tags (start with “//<![CDATA[“ and end with “//]]>” ), results in perfect upgrade to RH11. Please note that there was start of CDATA missing in the second script tag of your shared topic.

                 

                Please follow the proper syntax in the topic's HTML and it shouldn't be any issue with upgrade to RH11.

                 

                Kindly Regards,

                Vikas Singla

                RoboHelp Team

                Technical Communication Suite | RoboHelphttp://www.adobe.com/in/products/robohelp.html| RoboHelp Server