5 Replies Latest reply on Aug 29, 2014 1:43 AM by Anton Azarov

    .Wav file's volume being ignored

    GoodNewsJim Level 1

      Hello,

       

      I reduced the volume of a .wav file in audacity.

       

      When I load in audacity, the volume is less.

       

      But when I import to Flash Professional, the volume is not lowered at all.

       

      What should I do to lower the default starting volume?

       

      ,Jim

        • 1. Re: .Wav file's volume being ignored
          kglad Adobe Community Professional & MVP

          if you're adding your sound to a timeline, open the properties panel with that keyframe selected and, next to the effects combobox is a edit sound envelope icon which you can click and edit the sound's volume.

           

          if you use actionscript to create your sound, adjust the volume of the sound's soundchannel.

          1 person found this helpful
          • 2. Re: .Wav file's volume being ignored
            GoodNewsJim Level 1

            I already adjust music volume levels in game with a slider control.

             

            What I want to do is change the default volume coming in so it is on par with the other music. 

             

            I should be able to do this by changing the volume in audacity.

             

            It seems like Flash Professional has a bug where it can't read in adjusted volume.

             

            If all the music is about the same volume level, then the slider for music volume will be consistent.

            • 3. Re: .Wav file's volume being ignored
              kglad Adobe Community Professional & MVP

              i've not had that problem with audacity and flash but it's easy enough to compensate and "normalize" all your sounds' volume levels.

               

              so, if you have inconsistant 100% sound volume levels and you want to control them all with sliders, instead of the sliders directly controlling the sounds' volumes, have it control a "normalized" variable that you assign for each sound.

               

              for example if s1 is a sound that plays appropriately at 100% volume and s2 plays too loud (but at 80% volume matches the s1 100% volume), use:

               

              var s1MaxVol:Number=1;

              var s2MaxVol:Number=.8;

               

              then when you're assigning sound volumes, you would use something like:

               

              // for whateverSound with soundchannel=whateverSoundChannel and parameter = whateverSoundMaxVol set above

              sound_transform.volume=whateverSoundMaxVol*your_slider_value;

              whateverSoundChannel.soundTransform=sound_transform;

              1 person found this helpful
              • 4. Re: .Wav file's volume being ignored
                GoodNewsJim Level 1

                kglad, 

                 

                I know that hack and that is what I'm using.  I was just wondering why Adobe Flash Professional can't read in a volume level from a .wav.  That seems like it should be easy to do.  Are there plans to fix it?  It is much easier to fix the volume level using a sound editor's tools than for me to manually kludge numbers together because Adobe doesn't believe in fully conforming to standards of .wav files.

                 

                ,Jim

                • 5. Re: .Wav file's volume being ignored
                  Anton Azarov Level 3

                  Try to save your *.wav files with 44100 with Stereo properties.

                  1 person found this helpful