2 Replies Latest reply on Feb 18, 2014 2:49 PM by eileendigi

    Problem with Color Picker Tool

    eileendigi

      For some reason, out of the blue, my color picker is malfunctioning.  Every time I click on the "D" for default black and white, I get an error message that says "could not complete your request because of a program error".  I am working on a mask and need to be able to switch back and for between the two to accomplish my work.  Having this message pop up EVERY time I click on "D" for default colors or "X" to switch the two colors is making the work impossibly difficult.  Strangely, I notice that even if I change to a color other than black or white, I still get the message, but when I use my brush on the workspace the color I have chose shows but it does not show up on the little swatch for the foreground/background tool on the tools panel. 

       

      I am using an IMAC with OSX 10.8.5.  PLEASE, somebody help me!!

       

      Thanks,

      Eileen

        • 1. Re: Problem with Color Picker Tool
          Trevor.Dennis Adobe Community Professional

          Hi Eileen.  The first step is to reset Preferences as it so often fixes weird behavior.  Hold down Shift Cmd Opt while starting Photoshop.

           

          Some of what you describe is normal behaviour when working on a mask whether it is a layer mask or Quickmask.  If you select red, for instance, the foreground will show as a light grey.

          • 2. Re: Problem with Color Picker Tool
            eileendigi Level 1

            Thanks Trevor.  I did discover the option to reset all tools and that solved the problem.  It wasn't the normal behavior you mentioned.  I've become pretty familiar with Photoshop and this was a very strange behavior for sure.  I'm just glad that the rest tool solved it.  Appreciate your help, though.