1 Reply Latest reply on Feb 18, 2014 1:34 PM by Chris Cox

    Installing PS 7.0

    LWSchauf

      My DVD for PhotoShop 7.0 which was never registered, comes up when trying to install it on a brand new Maverick iMac with the message that it cannot installed because the computer is a power Macintosh. It certainly is not a power Macintosh! Is there anyway that I can get around this problem? Adobe's answer to this it was to pose the question here.

        • 1. Re: Installing PS 7.0
          Level 7

          No, because MacOS 10.9 only runs on Intel based Macintoshes.

          PowerPC based machines cannot run recent versions of MacOS.

          And Photoshop 7.0 was written for PowerPC (predating the move to Intel processors).

           

          No, there is no way around that problem. You need a newer version of Photoshop to run on Intel based machines.