1 Reply Latest reply on Jun 26, 2006 5:07 AM by

    Stuck in the very start

      Hi.
      I'm new to ActionScript and tried to solve this problem by using google and so on, but all answers i got are like "check if server running" and "check if application folder exists" and "check your firewall settings". Tried all this, nothing works.

      The description of the problem is as follows:
      I'm trying to start with MediaServer making a simple tutorial, like tutorial_hello, which is supposed to send a message to Media Server and echo it back.

      I create a flash file with an input field, push button and text field for echo messages. See the attached code - I've just copypasted it from the tutorial.

      The problem is that i got "Level: error Code: NetConnection.Connect.Failed" every time I try to connect. No matter how I try to connect, either rtmp:/tutorial_hello or rtmp://127.0.0.1/tutorial_hello/, or rtmp://localhost/tutorial_hello/room_01/, or rtmp://192.168.0.4/tutorial_hello, you name it. I do have the application directory in my Flash Media Server applications/ directory and i have main.asc file there containing server-side code (see attach), but I guess this code is not the point.
      The most confusing part of that is that I do see the connections to server in the administration console, like

      Connects Disconnects
      12 12

      and those numbers increase every time I try to connect and get a connection error.
      Firewall settings are ok too - i've even turned off the firewall to test it.
      Please help me debug this issue as I just can't move on to the more complex stuff from this very start. Thanks.
        • 1. Re: Stuck in the very start
          Thanks to everyone trying to help, i've found the problem. It appeared to be a http sniffer software installed on the server. Server installation instructions say

          "Software designed to make network connections mimic modems or DSL lines in order to save bandwidth, such as NetLimiter, can intercept system calls and break Flash Media Server socket actions. The error message "Failed to Attach Completion Port, the parameter is incorrect" appears. Before installing Flash Media Server, remove this type of software."

          Uninstalling sniffers solved the problem.