2 Replies Latest reply on Mar 1, 2014 2:10 PM by vfxKid1024

    Can't get Typekit to work with localhost (also, another weird issue with copy+paste)




      I've searched through the other posts already, and I *think* I've tried all the solutions, but I still can't get the typekit fonts on my machine.


      I'm trying to use the "orator-std" font.  In the "kit editor", in the "kit settings -> kit settings" tab I have for name "localhost" (w/o quotes) and for domains just "" (w/o quotes).


      Then (AFTER saving the settings from that tab), I go back into edge animate, I start a new font by clicking that + sign next to "fonts", in the "library" tab.  I set the "font fallback list" to ' "orator-std",sans-serif ' (w/ quotes, w/o single quotes), and then go back to the open browser and go to the "embed code", copy both lines of javascript, go back to edge animate, and... nothing.  It won't let me change ANY text in this box anymore after the window loses focus.  I have to press "cancel" and try again.  So this time, I just type in the orator-std... blah blah, same as last time, but paste in the code successfully as it was already in the clipboard and I didn't need to make the window lose focus.  Okay, so I click "Add font", and apply the font to my text.  Nothing happens.


      Huh... well the "Font's from T" picture is showing up in the bottom right of my screen, so that's odd.  I go to preview in chrome, still ugly old sans-seriff there, also with the "Font's from T" logo in the bottom right.


      I figure "okay, probably just takes a second... or a minute... or w/e like the message said."  Well this was at least an hour ago, so something is still wrong.


      I would love to just delete the font and start from scratch... maybe something got screwed up along the way and it would fix things to just start from scratch.  Well... "sorry" says edge animate... can't let you delete that!  In the "libarary" tab, there's only one font visible, it says "orator-std,sans-serif" (w/o quotes).  If I right click it, the only option is "delete" and it's greyed out.


      I tried doing one with arial instead of sans-serif just now, still not working, but everything shows up in arial now instead of sans-serif... so that's something I guess.


      Apologies if this is just a simple problem that I'm just somehow not grasping.  Please accept this legitimate bug report as payment... the er copy paste bug, I mean...