1 Reply Latest reply on Mar 1, 2014 12:05 PM by Mike M

    install problems

    Jackienme10

      cannot install latest version on mac os x version 10.5.8

        • 1. Re: install problems
          Mike M Level 6

          Jackienme10 wrote:

           

          cannot install latest version on mac os x version 10.5.8

          No.. you can't.

          10.3.183.90 is the final build that will run on OS 10.5.8.

          Leopard was the last "Universal Binary OS that Mac released. Because it must have components for PPC architecture, which hasn't been supported, even by Apple, for nearly five years, Adobe no longer updates Flash Player for it.

           

          If you have an Intel™ Mac (Core2™ Duo), you NEED TO upgrade to OS 10.6. or you've reached the end of the road for nearly ALL software. Apple sells it for $19.99 and they ship it free.

           

          If you have a PowerPC Model, you really need to look at getting a New Mac, because sadly, yours is obsolete, due to the hardware in it.