7 Replies Latest reply on Mar 2, 2014 12:27 PM by Steve Grisetti

    Help

    vintageclaret

      Just loaded Premiere Elements 11 onto Mac.  I loaded media but cannot get video or anything to play.  I can toggle between Play and Pause but no movement along timeline ?

        • 1. Re: Help
          Steve Grisetti Adobe Community Professional

          What model of camcorder is your video coming from and what format and resolution is it?

           

          How did you get this video from the camcorder to your computer?

           

          Have registered and signed in with your Adobe ID and then loaded the video clip to your timeline?

           

          It might also help to know what processor you're running. Some MacBook Air's, for instance, may be way underpowered for some video editing.

          1 person found this helpful
          • 2. Re: Help
            the_wine_snob Level 9

            Welcome to the forum.

             

            Can you let us know a bit more about your PrE Project, please?

             

            1. What OS version are you using?
            2. Did you download and install this version of PrE from the Adobe download Web site, or from the Apple App Store?
            3. What are the full specs. of the Imported Asset files?
            4. What Project Setting did you use, or did you let PrE select that, from the first Imported video file?

             

            Good luck, and let us know a bit more, please.

             

            Hunt

            1 person found this helpful
            • 3. Re: Help
              Steve Grisetti Adobe Community Professional

              Also please advise us if you purchased Premiere Elements from the App Store.

               

              App Store versions of the program have been known to be pretty buggy.

              • 4. Re: Help
                vintageclaret Level 1

                I loaded a series of photographs and tried to create instant video.  My computer is top of range iMac so processor shouldnt be an issue.  I am registered with Adobe.  Thanks.

                 

                This is a new registered copy of Premiere Elements.

                • 5. Re: Help
                  vintageclaret Level 1

                  The copy was from disk that I got bundled free with a Canon camera.  It was loaded via disk drive.  I have tried loading jpeg photos and various video types.  I can drag along the timeline but cannot get play to respond.  I didnt alter any settings.  Thanks

                  • 6. Re: Help
                    A.T. Romano Level 7

                    vintageclaret

                     

                    If your copy of Premiere Elements 11 does not say Adobe Premiere Elements 11 Editor, then the following may be the way to go....

                     

                    Replace installation files way....

                     

                    Download and install Premiere Elements 11 Mac from the following web site and then insert your purchased serial number into it at installation of it.

                    http://prodesigntools.com/photoshop-elements-11-direct-download-links-pse-premiere-pre.htm l

                     

                    It is critical that you read carefully the Note: Very Important Instruction before you attempt to click on the file download link. Otherwise you will be greeted with Access Denied message.

                     

                    Please review and then let us know the outcome.

                     

                    Thank you.

                     

                    ATR

                    • 7. Re: Help
                      Steve Grisetti Adobe Community Professional

                      Also, did you resize all of the photos to no larger than 1000x750 in size, per our recommendation on this site and in my books?

                       

                      Using full-sized photos is the chief reason this program overloads and crashes.