3 Replies Latest reply on Mar 4, 2014 9:43 PM by pwillener

    Distrust of Adobe Flash Player Update - Certificate has expired

    John Cee Level 1

      Couldn't find answer on Adobe.com.  Why should (or How do) I trust an "Adobe" Flash Player update that has an expired certificate?  Seems like a basic security vulnerability to me.

       

      My rig: Win 7 (64b), IE 11.