5 Replies Latest reply on Aug 21, 2014 9:51 PM by jbjnc

    error getting license. license server communication problem: e_adept_document_type_unknown

    digging4roots

      I began this day with ADE 17.2 and tried every proffered solution to no avail. The last suggestion was to update to ADE 3.0.

       

      The exact error message is:

      Unable to download. error getting license. license server communication problem: e_adept_document_type_unknown

       

      I have tried completely disabling the firewall (domain, public, private) and the problem persists. I have tried running ADE as system admin with same results.

       

      I've read all the posts on this forum and it appears no one has found a solution.

       

      Please note: I do not have a proxy, currently all firewalls disabled, no anti-virus software used.

      Windows 7 SP 1 32 bit home premium

      Firefox 27.0.1

      Shockwave flash 12.0.0.70

      Network connection is wifi home network

      Content to be downloaded is PDF from Google Play Books

       

      Is there anyone who can offer a solution ....

       

      UPDATE:

      My husband figured out how to disable the firewall on the router and we tested again (and simultaneiously with software firewall disabled). Still didn't work.

       

      I also created a Firewall Rule specifically for this application:

      GENERAL

      Name: Adobe Digital Editions 3.0

      [x] Enabled

      Action: Allow the connection

      PROGRAMS AND SERVICES

      This program: [local path to]\DigitalEditions.exe

      Services: apply to all programs and services

      COMPUTERS

      [nothing selected]

      PROTOCOLS AND PORTS

      Protocol type: any

      local port: all

      remote port: all

      ICMP: [default]

      SCOPE

      local IP: any

      remote IP: any

      ADVANCED

      Profiles: domain, public, private

      interface types: [default]

      Edge traversal: defer to application

      USERS

      [defaults]

      Authorized: [nothing entered]

      Exceptions: [nothing entered]

       

      UPDATE:

      I was reading other posts on similar topics and one of the suggestions was to try OverDrive. Since I already have it, I tried it and received the following error message:

       

      The specified OverDrive media file "[local path]\AppData\Local\Temp\Seams-Unlikely-epub-2.acsm" is not valid. (The OverDrive media file root element is not valid.)

       

      According to OverDrive's help forum that means the ACSM file can ONLY be downloaded with ADE!

      http://help.overdrive.com/article/0644/What-to-do-if-you-get-an-ACSM-The-OverDrive-media-f ile-root-element-is-not-valid-error-when-using-OverDrive-Media-Console-for-Windows-or-Mac

       

      UPDATE

      Have learned we have a WNDR4500 router with built-in firewall which can not be disabled. On the NetGear forums, there was the uninformative suggestion to "use DMZ in the router settings" to disable the firewall. In looking at the settings for our firewall, the nearest screen I could find to resemble that suggestion contained the following:

       

      [ ] Disable Port Scan and DoS Protection

      [ ] Default DMZ Server [192.168.1.0]

      [ ] Respond to Ping on Internet Port

      [x] Disable IGMP Proxying

      MTU Size(in bytes) 1500 bytes

      NAT Filtering [x] secured [ ] open

      [ ] Disable SIP ALG

       

      I'm afraid this is beyond the scope of my understanding and have no idea what I should be doing here so have made no changes.