2 Replies Latest reply: Mar 12, 2014 1:30 AM by Robin Bassett RSS

    Problems with HLS streaming when HDS works

    Robin Bassett Community Member

      I have followed several tutorials and done several tests on our live stream but although multibitrate streams work for HDS delivery in and outside our firewall having no luck delivering HLS delivery to IOS devices (iPhone 5S) neither inside or outside our organisation. I have set all the following :

       

      H.264, AAC audio at 44.1KHz Stereo 128kbit

      Profile: Main          Level:3.1          Keyframe Frequency: 4 seconds

      3 bitrates :

      150kbps at 320x240

      500 at 320x240

      700 at 320x240

       

      encoding to our server rtmp:[server ip]/livepkgr

      stream : livestream%i?adbe-live-event=liveevent

      I have set the synchronisation parameter in FMLE to true

       

      On the AMS server I have created two manifest files for the for f4m and m3u8 with the 3 streams as shown in several online documents using the built in tool in AMS 5.

       

      All port settings are the standard ones set on installation. I have also created a crossdomain.xml file again as explained in a online post with it set to all domains (yes I know it's not secure but I just want this thing to work!!)

       

      Has anyone got any idea where I'm going wrong or is it just a problem associated with our firewall (which I don't control!!)? The firewall/webfilter is by Watchguard does anyone know if there is an issue with this or how to set the ports up if they are wrong?

        • 1. Re: Problems with HLS streaming when HDS works
          Carlos1327 Community Member

          I'm having the opposite problem when I came across your thread. Follow the steps in the article below and see if any of the steps help:

          http://help.adobe.com/en_US/flashmediaserver/devguide/WS0432746db30523c21e63e3d12efac195bd -8000.html

           

           

          1. Have you configured the ports? Specifically:

          Configure Apache to use port 80 and configure Flash Media Server not to use port 80

          1. Configure Apache to use port 80.
            1. Open rootinstall/Apache2.2/conf in a text editor.
            2. Change the line Listen 8134 to Listen 80.
            3. Restart Apache. See Start and stop the server.
          2. Configure Flash Media Server not to use port 80.
            1. Open rootinstall/conf/fms.ini in a text editor.
            2. Remove 80 from the ADAPTOR.HOSTPORT parameter so the parameter looks like the following:ADAPTOR.HOSTPORT = :1935
            3. Restart Flash Media Server. See Start and stop the server.

           

           

          2. Have you verified that HLS streaming is working? Go to the videoplayer.html (in the samples folder) and try playing some HLS files or try opening the m3u8 set manifest file from localhost on an iPad.

           

          I would also try to get a single stream working first before you attempt to get the multi-bitrate live streaming working: http://help.adobe.com/en_US/flashmediaserver/devguide/WSd391de4d9c7bd609-52e437a812a3725df a0-8000.html

           

          Hopefully someone with more experience can help. Good luck.

          • 2. Re: Problems with HLS streaming when HDS works
            Robin Bassett Community Member

            Thanks Carlos I tried again with the single stream and managed to get it to work at a reasonable bit rate  - however If I change the output size beyond the standard 320x240 the received and encoded video is all broken up. Now that's fine until you want to use it full screen  with the output at 320x240 but it then looks blurry and pixelated. Any ideas why this might be so or is it just limited hardware; the encoder is an iMac with intel core 2 duo processor 4 GB RAM running Mountain Lion and when view the output after encoding there it's all good, but may be the server which is a Dell Intel Xeon E3120 with 4GB RAM running Windows 2008 R2 Service Pack 1.

             

            Not tried the Multibitrate variety yet.

             

            Thanks for your help

             

            Robin