2 Replies Latest reply on Jun 26, 2006 7:16 AM by Cliop

    Website Actionscript Help Needed

    Cliop
      So this is how it goes...I've already made my website, I have all the pages and everything made BUT...I have a few bugs. The first starts at my login page, it is a universal login, so it has 2 usernames and passwords, I have the code for it but, It does not go when I press the submit button. The next is when I get to my actual website, all the webpages are all in different scenes. I type in the code: on (press) {gotoAndPlay ("1","Corp") ; } but it just goes the scene up next. I have no clue what is wrong here. I also have a flaw with my loading page, whether than just loads fast or not, the loading movie does not loop until the movie is loaded. This page is also part of the movie. Can anyone help? The web address is: http://www.freewebs.com/cliop/ The code I am using on the button in my intro is:
      on (press) {
      if (username == "Cliop" or username == "X844495") {
      if (password == "*********" or password == "*********") {
      if (username== "Cliop" & password== "*********" or username== "X844495" & password== "*********") {
      gotoAndPlay("1", "Main");
      }
      }
      }
      }
        • 1. Re: Website Actionscript Help Needed
          Cliop Level 1
          I can't see the problem, I've tried the gotoAndStop tag, but it doesn't go anywhere when I press the button. I wonder.......
          • 2. Website Actionscript Help Needed
            Cliop Level 1
            I've tried a new code for my submit button:
            on (press) {
            if (username === "Cliop" or username === "X844495"); {
            if (password === "moocowman" or password === "shadowman"); {
            if (username === "Cliop" & password === "moocowman" or username === "X844495" & password === "shadowman"); {
            gotoAndPlay("1", "Main");
            }
            }
            }
            }

            else on (press){
            if (username !== "Cliop" or username !== "X844495"); {
            if (password !== "moocowman" or password !== "shadowman"); {
            if (username !== "Cliop" & password !== "moocowman" or username !== "X844495" & password !== "shadowman"); {
            stop();
            }
            }
            }
            }

            I still have problems, I type in the right username & password, yet I don't enter the website. It keeps giving me this: **Error** Scene=Intro, layer=otherpages, frame=212:Line 11: 'else' encountered without matching 'if'
            else on (press){
            Can anyone help me? I'm also still having problems with the navigation.