4 Replies Latest reply on Mar 12, 2014 10:04 AM by james.m

    Disable "Darkening" when editing a symbol


      In my workflow, I am constantly editing symbols.  However, when I enter a symbol, the stage is "darkened".   The result is that I cannot effectively gauge colors as I edit symbol elements.  How can I disable this "darkening" and see the normal colors?

        • 1. Re: Disable "Darkening" when editing a symbol
          heathrowe Most Valuable Participant

          There are two Edit Symbols modes.


          1. I suspect you are doing this one: Edit in Place Mode - is when you double click ( or Right Click > Edit Symbol ) directly onto the Symbol icon in the Elements Panel or directly onto the Stage. This is the method that produces the 'darkened' overlay so you can see it 'in place' relative to the rest of the stage.


          2. The other option is to double click ( or Right Click > Edit Symbol ) directly onto the symbol icon that resides in the Symbol Panel. This will not show overlay and the rest of the background is white.



          • 2. Re: Disable "Darkening" when editing a symbol
            james.m Level 1

            Thanks.  Actually I was doing #2 already.   However I just realized that I have a nearly white-offwhite gradient background image on the main stage, and when I go to Edit symbol mode, it has a grey background.  This was what was making it look wrong and darker.


            It seems the workaround is to copy my main stage background image into each of my symbols, while I edit, then hide or delete it at the end.  Otherwise I have no way of telling how the colors are looking relative to the whole composition. 


            The solution would be for me to be able to have a transparent stage when editing the symbol, and not have the darkening effect.  


            EDIT: No, actually it does mess up the colors even if I put the background image in the symbol.  It seems it adds a 10% darkening effect in Edit Symbol mode, vs a 50% in In Place Editing.  This is really frustrating.




            • 3. Re: Disable "Darkening" when editing a symbol
              heathrowe Most Valuable Participant

              I don't quite understand your frustration, to be honest.


              Direct editing of the Symbol ala Symbols Panel will only show the bounds of the Symbol, excluding the Main Stage. The background color you see here in this edit mode is the color of the dominant element WITHIN this Symbol. May it be background color or an element that completly covers the symbol stage.


              Edit in Place, well, is supposed to assist in isolating its position relative to the rest of the Stage.


              There is no user-defined Preferences area within Edge, and certainly your suggestion could fit into that category.

              I'd direct you to the feature request form, here - https://www.adobe.com/cfusion/mmform/index.cfm?name=wishform but just realized Edge Animate is not even in the list. So hopefully a dev menber can see and take your request.



              1 person found this helpful
              • 4. Re: Disable "Darkening" when editing a symbol
                james.m Level 1

                I don't mean to be unapreciative.  It's just that I go into a symbol, for example a button, set the color just right , say a nice azure blue, and then I set the text in a perfectly contrasting color, then I go back to the main stage and the colors are different.   That's a problem, and I no matter what I do, I can't get the colors while I'm editing to be the same as the colors while I'm viewing the main stage.  In fact, just clicking around on different elements in the symbol makes the "overlay" change slightly.  I think it's a bug, because sometimes clicking on one div, then clicking back on where I was doesn't bring me back to the previous colors.  I can see an effect that looks exactly like when you take a 24 bit color image and change it to a 256 color image.