6 Replies Latest reply on Mar 26, 2014 9:26 AM by Herbert2001

    3d extrusion gets unknown noise upon rendering?

    coonasty Level 1

      photoshop cc--I have a simple text extrusion.  added that bubble out bevel and added some shine and reflection in the materials section.  everything looks perfect on my screen till i hit render then noise just comes out of nowhere in the paint of the letters.  been playing with the settings but i cant figure out whats adding that noise.  anyone have an idea?  TIA

        • 1. Re: 3d extrusion gets unknown noise upon rendering?
          Mylenium Most Valuable Participant

          We can't know. You have not provided proper technical info or for that matter a screenshot. Sorry, but you're talking about colors to a blind man.

           

          Mylenium

          • 2. Re: 3d extrusion gets unknown noise upon rendering?
            coonasty Level 1

            ah sorry bout that.  here's another test and from the get go it add's noise to the entire extrusion.  pic 1 looks great before the render.  pic2 is right upon starting the render...you can see the noise pop up and start baking in.  then pic3 is end of render with noise in text. 

             

            im hoping its just a simple setting im missing.  so far every extrusion ive done has this noise in it when i start the render.  starting from last night through this morning.  however i did do one 3 or 4 days ago that came out perfect.

             

            http://imgur.com/FYjmgqVhttp://imgur.com/MFKIm9Phttp://imgur.com/LtNxfFm

            • 3. Re: 3d extrusion gets unknown noise upon rendering?
              coonasty Level 1

              hoping someone knows what this is.  here's another pic but somehow i got the front face (pink) to start to render with no noise at all.  just the bevel and sides have the noise. i dont know what i hit to remove the noise from the pink face.  i have tried what i think is every setting on bevel and sides and doesnt seem to go away.  i really hope someone knows what is causing this.  again TIAnoise4.jpg

              • 4. Re: 3d extrusion gets unknown noise upon rendering?
                coonasty Level 1

                yay!!! found the answer on another forum.  in the evironment section under the global ambient, i turned off the shadow and that did it.  not sure why it shows up as noise and not a soft shadow (turning up softness to 100% still had the noise). 

                1 person found this helpful
                • 5. Re: 3d extrusion gets unknown noise upon rendering?
                  Herbert2001 Level 4

                  That's the nature of 3d rendering - you will just have to give it more render time to resolve the noise in the render. Depending on the render algorithm noise is a typical issue in shadow areas of a rendered image. To reduce the noise it will take more render samples, which translates in (much) more time.

                   

                  Alternatively, you could use a plugin like neat image or noise ninja to reduce the noise. It's a trick applied by 3d professionals as well.

                   

                  There is noise in the pink, just not very apparent because it is a flat surface, with less shadows compared to the rounded version you posted before.

                   

                  Either way, Photoshop's render quality is arguably rather low quality, and quite old-fashioned (and VERY slow) compared to 3d software.

                   

                  An alternative approach is to export the 3d object out of Photoshop, and use a third-party renderer. For example, Blender (which also has Nvidia GPU accelerated rendering built in - it's super fast). But that would mean a more convoluted workflow and learning other software.

                  • 6. Re: 3d extrusion gets unknown noise upon rendering?
                    Herbert2001 Level 4

                    coonasty wrote:

                     

                    yay!!! found the answer on another forum.  in the evironment section under the global ambient, i turned off the shadow and that did it.  not sure why it shows up as noise and not a soft shadow (turning up softness to 100% still had the noise). 

                    Because a very different shadow algorithm is used when you turn off that shadow - when turned off, it will render straight ray traced shadows, which do not support more realistic looking shadows. Probably ambient occlusion is added when you click that shadow checkbox - which can be very noisy unless enough samples are made (longer render times).

                     

                    You probably noticed a jump in render speed as well? That is because again the letters are now rendered in straight up ray tracing, which tends to be quite fast.