5 Replies Latest reply on Mar 17, 2014 7:53 AM by Willi Adelberger

    Text Autoflow randomly leaves gaps

    cadoyle

      I'm currently editing a series of files for a teaching guide.  It's a mixture of text, tables and graphics. 

       

      I am having random issues with the text flow, where it will leave huge gaps between paragraphs - or even break the paragraph (not necessarily following a widow/orphan line rule).  It occurs before I put any of the graphics in - in fact, the current chapter doesn't have any.  I've tried forcing line breaks, carriage returns, etc.  It doesn't seem to make a difference if I have a long paragraph or bulleted lists.

       

      I'm attaching the first two pages of the current chapter so you can see what's happening.  That really big gap on the second page isn't supposed to be there.   (these are screen grabs, so the sizing is off)

       

      Thoughts? 

       

      CS5 (Version 7.0), on a MacPro 10.7.5, 12 core Intel processor, 8GB ram.

       

      Thanks!

      Page89.jpgPage90.jpg

        • 1. Re: Text Autoflow randomly leaves gaps
          Willi Adelberger Most Valuable Participant

          I don't know exactly what you mean, but I see a lot of typesetting problems:

          1. Never use more than 1 successive normal spaces. Space has no fixed width. If you need more space, use either a fixed (or if you want several different) width spaces or better a tabulator. You insert also an additional space after a dot. This is with todays programs not good.
          2. Never use 2 return to force spaces between paragraphs. If you need spaces between use space before and space after. Otherwise keep options become obsolete.
          3. You draw a background frame and draw another frame for text a little bit smaller above it. Don't! Write the text inside the very same frame as the background is. It makes no sense to do otherwise, except if in thebackground is an image, not a color.
          4. Use pareagraph styles. I don't see, that you are using para styles.
          5. Use dedicated para styles for your numbered lists. They will do the numbering automatically. Use for each level, number and letter a different style, define the distance between number/dot and text with a tabulator in the paragraph style, not with 2 successive spaces.
          6. Use less independend frames, e.g. you have "18. man…", the name and the yellow backound mde with 3 different frames. 1 yellow frame with all text would be enough. More is worse.
          7. Use automatic page numberingfrom your master page, don't insert it manually.

           

          // I think when you observe my points your problem will disappear. I think I detected now your problem. It is found in the keep options. Show us you keep options in the paragraph style (You have to use styles!).

           

          Nachricht geändert durch Willi Adelberger

          • 2. Re: Text Autoflow randomly leaves gaps
            Peter Spier Most Valuable Participant (Moderator)

            First, make sure you've updated CS5 to version 7.0.4.

             

            The problem appears to be one of Keep Options applied tothe block of type after the first paragraph at teh top of the second page. Something in those options is preventing ID from breaking the text in those paragraphs.

            • 3. Re: Text Autoflow randomly leaves gaps
              cadoyle Level 1

              Thank you to both Willi and Peter.  It was indeed the Keep Options that was the problem.

               

              I am doing several of the things Willi noted, but since I am importing the text from a Word document, which was written by someone else, the underlying formatting can be quite unpredictable.  In particular, the paragraph styles often don't apply consistently.

              • 4. Re: Text Autoflow randomly leaves gaps
                Peter Spier Most Valuable Participant (Moderator)

                You can use the FindChangeBy LIst.jsx sample script to clean up most of what Willi pointed out.

                • 5. Re: Text Autoflow randomly leaves gaps
                  Willi Adelberger Most Valuable Participant

                  A lot of the problems can be cleand up via find & replace and GREP. You have to create once your own stylen then you can delete all imported styles and apply it to your document.

                  And the rulea I have mentioned above are also valid in a Word document. If these rules are oberved in Word it makes editing in InDesign much easier.