0 Replies Latest reply on Mar 23, 2014 7:23 AM by jabir ali raju

    I am using strobe player in flex builder 4.6 but its not loading.

    jabir ali raju

      I am using strobe player in flex builder 4.6 but its not loading,

      I have made required change in compiler option as below: 

       

      -locale en_US -swf-version=11 -define CONFIG::LOGGING true -define CONFIG::FLASH_10_1 true -define CONFIG::MOCK false -define CONFIG::PLATFORM true

       

      There is no any error but player does not load, here is my code I am using;

       

      <?xml version="1.0" encoding="utf-8"?>

      <s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"

            xmlns:s="library://ns.adobe.com/flex/spark"

            xmlns:mx="library://ns.adobe.com/flex/mx"

            applicationComplete="init(event)" backgroundAlpha="0">

      <fx:Declarations>

        <!-- Place non-visual elements (e.g., services, value objects) here -->

      </fx:Declarations>

      <fx:Script>

        <![CDATA[

         import mx.core.UIComponent;

       

         private const HTTP:String = "http://ec2-54-84-194-229.compute-1.amazonaws.com:1935/live/legacyLive/manifest.f4m?DVR";

       

         protected function init(event:Event):void

         {

          var playerInstance:StrobeMediaPlayback = new StrobeMediaPlayback();

           var ui:UIComponent = new UIComponent();

          var parameters:Object = {

           src:HTTP,

           controlBarMode:"floating",

           controlBarAutoHide:"true"

          };

       

          playerInstance.initialize(parameters, systemManager.stage, systemManager.loaderInfo, null);

       

          ui.addChild(playerInstance as DisplayObject);

       

          addChild(ui);

         }

        ]]>

      </fx:Script>

      </s:Application>