5 Replies Latest reply on Jun 20, 2014 10:39 AM by vishu#13

    CFv10: Mandatory Update Failure

    dtb26

      Hi,

       

      I'm currently installing CF 10 to a couple of Linux RedHat 6 x86_64 environments.  All is well until I attempt to update the installation.

       

      If I try to run any of the updates, I receive the following error:

       

                                     Error occurred while downloading the update: Failed Signature verification

       

       

      A little research taught me that adobe changed their code signing certificate; thus there is a mandatory update that must be run before any other can:   http://helpx.adobe.com/coldfusion/kb/coldfusion-10-mandatory-update.html  (I double checked our build number, we need this update).

       

      The update won't run.

       

      I followed the instructions found here: http://help.adobe.com/en_US/ColdFusion/10.0/Admin/WSe61e35da8d318518-33adffe0134c60cd31c-7 ffe.html  (we're running a standalone installation).

       

      I'm trying to work with the linux console mode instructions. I run:

       

      :/shell>sudo java -jar cf10_mdt_updt.jar

      (.:7367): Gtk-WARNING **: cannot open display:

       

       

      I also tried writing a conf file and running in silent mode:

       

      :/shell>sudo java -jar cf10_mdt_updt.jar -i silent -f ./properties_file

      (.:7440): Gtk-WARNING **: cannot open display:

       

       

      The properties file looks like:

       

      INSTALLER_UI=SILENT

      USER_INSTALL_DIR=[root dir]

      DOC_ROOT=[path to doc root]

      #The following applies only to multi server scenarios.

      #INSTANCE_LIST=cfusion,cfusion1

       

      It looks to me like the "console" version of this installer is attempting to leverage x11... which our servers are never going to install and run.  has anyone else run into this?  Is the installer really that badly conceived or am I doing something wrong?  is there a way to install this mandatory update in a commandline environment?

       

      Thank you

      Dave